it looks like my camera is missed but I still could use it by num 0 or ctrl+alt+num0.i just can't select it or select it under Scene Collection.enter image description here

  • $\begingroup$ Maybe you have no more camera object in your scene and you've made another camera? Check what object is selected as camera in the Scene panel > Scene > Camera $\endgroup$
    – moonboots
    Commented Dec 18, 2023 at 13:08
  • $\begingroup$ You cannot select camera because you are in Pose Mode $\endgroup$
    – MikoCG
    Commented Dec 18, 2023 at 13:08
  • 1
    $\begingroup$ @MikoCG Pose Mode does not hide cameras in the Outliner, if filtering for "camera" does not show anything this means either there is no camera object in the scene or if there is, both the object and the inherent object data have been renamed so that they are filtered out. If there is no camera object but a camera view, he has made a different object the active camera. $\endgroup$ Commented Dec 18, 2023 at 13:42
  • $\begingroup$ Open the filter menu (icon funnel) in the outliner and enable Cameras and/or Objects:all ? $\endgroup$
    – relaxed
    Commented Dec 18, 2023 at 16:48
  • $\begingroup$ Same as my case. Camera not shown in Scene Collection but numpad 0 still work. Any solution? Thanks $\endgroup$
    – CLIWIR
    Commented Mar 4 at 3:07

1 Answer 1


If there still is a camera object in your scene and filtering in the Outliner for "camera" does not show anything, then maybe you have changed both the name in the Object Properties and the Object Data Properties:

camera name

But maybe you accidentally deleted the camera object. The reason you can still switch to camera view with Numpad 0 or align the camera to the current viewport with Ctrl+Alt+Numpad 0 is most likely that you accidentally made a different object the active camera. This works by having any object selected and pressing Ctrl+Numpad 0 (this might have happened when you tried to align the view).

Now first of all go into Object Mode. To find out which object is the active camera, you can choose Select > Select Active Camera from the viewport menu. Now that the camera is selected, you can see the name of the object in the top left corner of the viewport - the name of the active object is always shown there when Overlays are enabled:

select active camera

showing the active object

If you still have no idea where the object is in the Viewport or in the Outliner, you can hit Numpad . in either of them to Frame Selected, which means the viewport gets centered and zoomed in on the selected object or in the Outliner, the hierarchy gets expanded to reveal where the selected object is located and jumps to the entry if the list is long.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .