1
$\begingroup$

My outline is showing the whole object instead of just the outline, It works in eevee but I need it in cycles here is my node set up for the object: enter image description here

render result: enter image description here

viewport result: enter image description here

I want it to look like it does in viewport.

$\endgroup$

1 Answer 1

2
$\begingroup$

The setup in EEVEE can be done with the following Geometry Nodes on the object.

GN 1

For this setup to work, the shader of the outline can be as simple as connecting a color node to the material output node as long as we enable Backface Culling in the material settings.

Shader 1

In Cycles, the above shader setup won't work as we don't have the aforementioned material setting. We'll need to render the backfaces transparent with a shader setup similar to the one you shared.

Shader 2

The issue here is the outline shell that we created in Geometry Nodes will cast shadows on the original object. This can be addressed by disabling Shadow rays on the object (Object Settings > Visibility > Ray Visibility).

Object 2

As you may have guessed, this will disable shadows for the whole object (it will have no shadows). There is another setup that doesn't have this issue, but it's a bit more complex. Simply put, we need the outline to be its own object. This way, we can disable Shadow rays for that outline independently from the main object. On that outline object, the Geometry Nodes will be slightly modified to read the geometry from our original object as shown in the screenshot below.

GN 3

Now, we have complete freedom to customize the rendering of the outline object. We can go as far as leaving only the Camera rays visibility on.

Object 3

Having to handle two objects instead of one is what makes this a bit more complex, but if you make it a child of the main object, it shouldn't be too bad.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .