0
$\begingroup$

In Blender 3.5 I made B the brush shortcut in Grease Pencil Draw mode, when I updated to Blender 4.0 the shortcut no longer works and starts a 'box selection' operation. The E shortcut for the eraser tool still works, though.

So far I've tried reinstalling, resetting all configurations and (obviously) tried re-binding the shortcut.

Anyone else getting this problem?

$\endgroup$
1
  • $\begingroup$ Some of the keymapping has changed with version 4 and Blender have provided a video detailing the changes here which might help. $\endgroup$
    – John Eason
    Dec 8, 2023 at 9:37

1 Answer 1

0
$\begingroup$

If one key is bound to multiple operators, only one will run and the rest will be ignored. In your situation, I think you just need to remove or change the B key binding for the operators you don't want. To list the B key bindings, in the preference:

  1. Click the Keymap button.
  2. Click the Key-Binding button.
  3. Type b in the search box.

Now, all you have to do is remove or change the bindings listed under Grease Pencil. If you want to target one mode only, you don't have to change the rest.

Keymap

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .