enter image description here

I usually use IRONCAD (CAD for mechanical design) in my work, and when I import a model created with this CAD into Blender, it is imported with a dirty division of the surface tangent to the curved surface, as shown in the attached image. I always have to manually fix this to a clean surface division, but it is very time consuming. Is there an add-on or other software conversion that can do this automatically, or is there some easy way to do this?

  • 2
    $\begingroup$ I'd be willing to bet on this not being an issue with Blender, but rather with whatever exporter you're using with IronCAD. I've never used IronCAD, but the Wikipedia lists the file formats it's capable of exporting, and at least three of these can be imported by Blender: OBJ, PLY and STL. Try all of them, and see if any give better subdivision. I wouldn't bet on it though, because the subdivision algorithm is probably shared among all exporters. $\endgroup$
    – user143855
    Commented Dec 7, 2023 at 6:32
  • 3
    $\begingroup$ If you don't mind getting n-gons (and trust me it is not true when people say you should always have quads), then simply go into Edit Mode, select all with A, then Xand choose Limited Dissolve. In the tool box at the bottom left you can then choose the options to be applied for dissolving edges and vertices. The default angle to which a corner is considered flat is 5°, usually I decrease it to 1° to make sure curved surfaced with a higher resolution are not dissolved. And just to make sure there are no duplicate vertices or unconnected adjacent faces, use M > Merge > By Distance. $\endgroup$ Commented Dec 7, 2023 at 7:02
  • 2
    $\begingroup$ "I import a model created with this CAD into Blender, it is imported with a dirty division" This seems to imply that it was Blender that created this topology which is almost certainly incorrect. Blender is not a CAD program, and as such this was most likely imported from some undisclosed mesh format, which Blender just read verbatim. If you are unhappy with the meshing result it has to be adjusted at the source CAD model on export, or using a better meshing algorith. There is nothing that can be done after the fact, other than manually adjust. $\endgroup$ Commented Dec 7, 2023 at 9:28
  • $\begingroup$ So the problem is in the CAD output stage (the way the solid model is converted to a mesh model), and there is no way to clean up the mesh division automatically after the fact with mesh-based software like Blender? I am convinced. $\endgroup$
    – taiga
    Commented Dec 8, 2023 at 7:43


You must log in to answer this question.

Browse other questions tagged .