6
$\begingroup$

I've searched the internet, and have seen the code which generates this error. While I've been a programmer for more years than I can remember, I'm still quite new to Blender (and I have a feeling, this can go on for quite a while in spite of handling a massive learning curve. ;-))

Anyway, I am making a model of my home, and I decided I wanted to separate the inner walls from the outer walls to place them in separate layers. Everything was going fairly well using rip. I would run across some duplicates, or the occasional mismatch in closeness which weren't merged. I handled by either merging, then ripping, or removing duplicates. However, I came across one wall section which just won't rip not matter what.

To me, I'm thinking that somehow Blender thinks one or more of the vertices belong to one piece, like the inner, and the other one or more of 4 belong to the other side, like the outer wall. And I'm getting the error message "Cannot rip multiple disconnected vertices", which according to the code, could be fixed, but apparently has yet to be done.

Details are included in the code as follows: "When calling edge split we operate on tagged edges rather then selected, this is important because the edges to operate on are extended by one."

So, this appears to be a problem with referencing the edges and what face they belong to, or some such thing. In a couple of cases, I deleted the faces, leaving only edges and vertices, and the rip worked, in another I had to excise a piece of the inner wall, and then grab and move the edge close, without merging the vertices, to keep the concept of separating the join, or basically unwelding (as I've heard some say).

But, this problem seems to show up a bit, now that it's reared its ugly head, and I'm hoping someone can tell me how to fix the problem mentioned in the code, or explain the difference between a "tagged" edge, vs a "selected" edge.

I have a feeling if this was an easy fix, it would have been fixed in code at creation; so, I'm presuming it's not an easy fix. This really impairs the Rip function, which is a very nice feature, from my understanding this is a new feature, and I feel fortunate that it exists at a time I'm just starting out in Blender.

So, is there any help out there on either fixing the specific problem regarding why there is a 'tagging' vs 'selected' problem. I do have a lengthy workaround; but, it would be nice to either see this fixed, or I could report it as a bug, or maybe something totally different?

$\endgroup$
  • 1
    $\begingroup$ if it is a bug and you can reproduce then it is worth doing a bug report developer.blender.org . $\endgroup$ – zeffii May 8 '15 at 20:58
  • $\begingroup$ What version of Blender are you using? Can you isolate the portion of the model that is causing problems and upload it to PasteAll.org with the link pasted in here? Are you using "rip", "rip-move"(also just called 'rip'), or "rip-move-fill"? $\endgroup$ – MarcClintDion May 9 '15 at 4:58
  • $\begingroup$ I think it would be beneficial if you could include an image of the mesh you are trying rip or even upload a blend file to blend-exchange.giantcowfilms.com $\endgroup$ – Ray Mairlot May 9 '15 at 16:41
  • $\begingroup$ Thanks, I would have filed bug; but, I'm impatient, and I found workarounds! I cut out a piece of the inner wall [delete], then deleted extra edges still connected to outside wall. At best it was a clean removal, at worst it left a missing face in the outer wall. Those that worked, I was able to select four vertices that were in common to both inner and outer wall, and it ripped just fine; Selecting the common face didn't work, giving the standard error about faces, so I used verts. I used "rip", don't know about rip-move-fill. $\endgroup$ – Cyberchipz May 18 '15 at 1:33
2
$\begingroup$

I think your problem is that you select all edges which together constructs a face, thats not possible, you have to unselect one edge to Rip that face, but then its same than Split-command to face.

$\endgroup$
  • $\begingroup$ I zoomed in very close and found that what I thought was one face was actually two faces, each having 3 vertices in common and one vertex each face not merged and independent. So one corner vertex that I though was one vertex was two vertices, so the two faces could not be ripped. Does that sound right? What I had done when I made them was assume all four vertices of an extrude were close enough to merge (when snapped) with the four vertices of the other object, but they were too far apart and only three vertices merged, one vertex did not merge, The merging planes not being parallel. $\endgroup$ – Cyberchipz May 13 '15 at 12:58
  • $\begingroup$ Thanks guys, I think the problems were multiple, when I made the join, I extruded faces that were not parallel with the joining face and some vertices merged, and others didn't. I probably need to loosen the tolerance for the merging vertices next time, even in carpentry 1/16" off is OK ;-) But, Blender can do thousandths of an inch, my merge vertex tolerance was too tight, if that can be set, not all vertices were merging when I joined during face extrude at build time, later I could not rip, I think. But, thanks for the suggestions. I'm still new. $\endgroup$ – Cyberchipz May 13 '15 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.