3
$\begingroup$

I'm trying to render a simple cosmetic lip balm tube. The body is made of blue and white plastic, while the overcap is made of clear plastic. When I produce a render, the overcap makes it look like the parts of the tube inside it are a very dark grey colour, when in fact they are not. When they're rendered individually, they look accurate, but when together the clear overcap obscures the white object.

The clear cap is a basic material which in the BSDF settings has transmission set to 1.0, IOR set to 1.1, and roughness set to 0.2. I believe this should make it like glass with a high level of optical transparency.

In Render Properties > Light Paths > Caustics is enabled for reflective and refractive.

I tried adding an additional light (a sun) but all this does is blow everything out except the top region I'm trying to illuminate.

I've attached a photograph of the real object. As you can see, the cap is crystal clear, and the internal coloured components are easily visible.

I am sure this is a simple fix. What am I missing?

Blend file here;

rendered altogether rendered without closure rendered without cosmetic body enter image description here actual object

$\endgroup$
2
  • $\begingroup$ just to elaborate, it's the basic principled BSDF shader, not a glass shader or anything like that. I did manage to achieve a version of the look I want, by going to the clear object and turning off shadows in the object properties > visibility > ray visibility section. It isn't the ideal solution though, so if anyone out there knows the more realistic way to do this, please let me know :) $\endgroup$
    – ScottF
    Commented Dec 4, 2023 at 5:32
  • $\begingroup$ Hello please share your file: blend-exchange.com $\endgroup$
    – moonboots
    Commented Dec 4, 2023 at 8:50

2 Answers 2

0
$\begingroup$

Grey color could appear because of the "transparent" piece is casting a shadow.

To check this possibility you could (temporary) disable it casting ANY shadows.

In transparent's material properties switch [Shadow Mode] to 'None' (like on the screenshot bellow)

If it helps, you have at least two options:

  1. Turn shadow back on. Then adjust lighting setup to change shadow's intensity.

  2. Keep shadow turned of - if it looks ok without it.

__

By the way, next time you ask a question – it's HIGLY recommended to attach your ".blend" file.

This helps to find a solution A LOT.

enter image description here



[UPD]:

After examing newly added file — I've found a solution to your problem.

But before I continue, I would like to mention: you've forgot to add an HDRI texture, which you used in the project.

For future reference :

Images are NOT being attach automatically to the project file. So every time you would like to share your project – you should:

EITHER pack all images into the .zip archive - additionally to the .blend file.

OR (even better) you can pack all images into the .blend file itself.

It could be done this way :

Packing textures into the .blend file


Since HDRI was missing I've used an arbitrary photo-studio HDRI from "Poly Haven"

And proper HDRI (solely) have done most of the work. Look :

new HDRI


Additional point light improved the result : new HDRI plus point light


Attaching fixed file (HDRI is packed in it) :


*By the way, this HDRI is free for use (CC0 license), you can download it here: ==LINK==


**Lighting setup in this project DEFENETELY could be elaborated even more – but I leave it to you and to your taste :-)


$\endgroup$
2
  • $\begingroup$ Hey thank you so much for taking the time to respond. Your solution of turning off the shadows is effective, and is close to the desired result, but as it is not as realistic as it should be I would still like to know if there is another way to solve it. One of the constraints I need to work to is that I need to stick to principled BSDF shader (not a glass shader). With the expertise in this forum, is it possible to achieve this effect using only the principled bsdf shader? <img src="https://blend-exchange.com/embedImage.png?bid=xaqZ6mNB" /> $\endgroup$
    – ScottF
    Commented Dec 4, 2023 at 22:35
  • 1
    $\begingroup$ >> "is it possible to achieve this effect using only the principled bsdf shader?" --- Yep! Updated the answer. Check it out :-) $\endgroup$
    – Yaroslav
    Commented Dec 6, 2023 at 4:20
1
$\begingroup$

In the Render panel, you have enable Fast GI Approximation but it seems like it doesn't work with glass, so disable it:

enter image description here

$\endgroup$
0

Not the answer you're looking for? Browse other questions tagged .