0
$\begingroup$

My faces have a weird shading to them even though the normals are facing the correct way. There are also no n-gons. When I import into substance it also looks warped.

How do I fix this issue?

enter image description here

enter image description here

enter image description here

enter image description here

https://mega.nz/file/KuYTGSBa#N_XIE9_6hwaLDLE3oil-pTeiAGkU5k4wZwuae_2-vHY

https://www.virustotal.com/gui/url/ffd1618da5df50df41ca145d84ef9082e2b3dfd20931e0c25b1b828fc6854b79?nocache=1

https://www.filescan.io/uploads/656a6d9d2efa450749b2e038/reports/19aa5b31-adb0-4eb2-b80b-bee5bc825758/overview

I noticed that when I select faces near each other they are separate on the UV map. Could this be the issue?

$\endgroup$
4
  • $\begingroup$ Have you got Shade Smooth on? Have you activated Auto Smooth in the Data Properties tab? $\endgroup$
    – Psyonic
    Dec 1, 2023 at 23:22
  • $\begingroup$ I think a file (with packed textures) would be very, very helpful for anyone that felt like helping. $\endgroup$
    – Nathan
    Dec 1, 2023 at 23:29
  • $\begingroup$ @Psyonic I do not have either of those enabled for this model. $\endgroup$
    – Aeryes
    Dec 1, 2023 at 23:31
  • $\begingroup$ @Nathan added a mega link for the file along with virus reports. $\endgroup$
    – Aeryes
    Dec 1, 2023 at 23:36

2 Answers 2

0
$\begingroup$

You've messed your normals somehow.

Edit the mesh, select all vertices and do Mesh > Normals > Reset Vectors.

This cleaned up most of it, but you also seem to have custom split normals as well, you'll need to clear them.
enter image description here

$\endgroup$
4
  • $\begingroup$ I did this but it did not change anything. When I remove the edges and redo the entire area the same thing keeps occurring. $\endgroup$
    – Aeryes
    Dec 2, 2023 at 0:42
  • $\begingroup$ @Aeryes I've revised my answer $\endgroup$
    – Psyonic
    Dec 2, 2023 at 1:10
  • $\begingroup$ That fixed it. How did that happen? I never changed anything to make those other than remove faces from a cube to create a desired shape. $\endgroup$
    – Aeryes
    Dec 2, 2023 at 1:20
  • $\begingroup$ You may have accidentally hit a key combo you didn't mean to, happens sometimes $\endgroup$
    – Psyonic
    Dec 2, 2023 at 3:00
0
$\begingroup$

The second thing I notice (after checking to verify normal direction) is that you have custom normals:

enter image description here

I know that this is the case because of the button in properties/object data/geometry data, that offers "clear custom normals". I have no idea what those custom normals are-- they could be anything. Let's clear them.

enter image description here

Now, we have what is basically a flat-shaded mesh. It's flat shaded because it's autosmoothed (also in properties/object data) to mark all edges representing a face angle of 30 degrees or greater as sharp. Is this what you want? Then you're done. Not what you want? We'll disable autosmooth:

enter image description here

Now, we have smooth shaded normals across the boundary faces. Of course, these smooth shaded normals are interpolating rather wildly, over +- 90 degrees across a single face. Perhaps we should add a few loop cuts, so that those normals only interpolate across 45 degrees, over a fraction of the faces:

enter image description here

We can create an additional loop to hold the interpolation of normals on the other side of the angle, and adjust the spacing of those loops we just made. There's no right answer here (it's not reality, it's a high-level abstraction of reality); we just do it to eye, until it does what we want:

enter image description here

There are ngons. But in this case, that's fine. For the surfaces we're concerned with, the ngons are planar with their neighbors. And because there are no packed textures, there's not yet any reason to care about the triangulation of distorted UV, not any reason to care about vertex color, which doesn't exist. So ngons are fine here. (And, since ngons are often easier to work with than quads, when they work, ngons are the appropriate thing to use here.)

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .