Loved the 4.0.1 update so far but i can't figure out how to get the top right toolbar back. Also magnetic tool and vertex snapping is missing. Doesn't show even in edit mode. I think it should be there because it is included in feature video: Blender 4.0 New Features Official Overview

Blender 3.6.4 viewport Blender 3.6.4 viewport Blender 4.0.1 new viewport, toolbar missing Blender 4.0.1 viewport

  • $\begingroup$ Can you add an image of the whole screen in Object mode please? (Window > Save Screenshot in Blender.) - The settings are a bit confusing and I might be able to create an answer with images if I can see what exact layout you currently have on the left of the screen $\endgroup$
    – John Eason
    Commented Nov 30, 2023 at 18:03
  • $\begingroup$ @JohnEason Thank you for reply, clearer screenshots added! $\endgroup$
    – Purde
    Commented Nov 30, 2023 at 18:39
  • $\begingroup$ It should be there. Have you tried to reset Blender to its factory settings? (menu File ► Default ► Load Factory Settings) to see if it helps? Otherwise, that might be a bug to report using the menu Help ► Report A Bug. $\endgroup$
    – Lauloque
    Commented Nov 30, 2023 at 19:04
  • $\begingroup$ @Purde Thanks for those images. Unfortunately it's not the problem I was expecting, but you don't seem to be the only person with that problem judging by this posting on Reddit. As L0Lock says I'd report it as a bug if loading factory settings doesn't work. :^( $\endgroup$
    – John Eason
    Commented Nov 30, 2023 at 22:31

1 Answer 1


Resetting to factory settings did help, thanks for the help! I suspect that the bug is something related to custom theme settings, as I made some adjustments way back in the 2.79 to 3.0 version transition.

If anyone else is experiencing the same bug, be sure to screenshot all enabled add-ons and export your own custom keymaps before trying to factory reset.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .