0
$\begingroup$

When using eevee and enabling "Scene World", with Mesh > Shading > Flat faces enabled, blurred and irregular shadows still appear. I have checked/recalculated the normals (they are all correctly oriented; Display > Face orientation shows all blue faces), cleared edges, and tried everything in Mesh > Clean up to no avail. I wonder if it is the topology, since I have a few triangles and even fewer n-gons? I have tried my best manually to make sure there are no extra faces/vertices either.

I would like to have all of the shading follow the rest of the body.

Thank you.

enter image description here

enter image description here

OBJECT smooth shading enabled: artifact still present

$\endgroup$
1
  • 2
    $\begingroup$ Shading > Flat only means that the the edge angles between faces are not smoothed out, i.e. you can see where one face ends and the other begins because of the harsh change in shading (if their normals are differing from each other). It has nothing to do with the shadow an object casts onto a surface. The sharpness of shadows depends on the Radius or Size you've set in the light properties, and when using Eevee instead of Cycles additionally also in the Shadow and/or Contact Shadows setting of the light and the Shadows settings in the scene's Render Properties. $\endgroup$ Commented Nov 30, 2023 at 13:01

0

You must log in to answer this question.

Browse other questions tagged .