0
$\begingroup$

My scene lighting works fine in the render preview but as soon as I go to do my final render it comes out as being too dark. I've tried everything, I've looked through all the lighting settings and my shaders! This has never happened in any of my previous projects. Will share file if it makes it easier to solve the problem!

This is an image of render preview enter image description here

This is an image of the final render enter image description here

Finally this is an image of a cube in the same exact blender file, the point light's lighting along with other lights seem to work. The only lighting in my scene is that of a HDRI which isn't showing up in the post render. enter image description here

finally (the part that confuses me the most) is that when I add a point light near my ocean modified object the lighting doesn't work which makes me think there is something wrong with my shader enter image description here

There is quite literally a light next to the water at 10000w but it is still dark, also finally finally when I turn off HDRI in render preview the point light doesn't work which really confuses me! enter image description here

$\endgroup$
6
  • 1
    $\begingroup$ Hello and welcome. As it stands this question is unanswerable and was put on hold for lack of essential details to understand the issue. Risking stating the obvious, only you have access to your scene, so unless you describe it thoroughly you alone know your exact setup, settings and what steps you took to arrive where your are now. Describe the issue in detail, add images of relevant settings and user interface, with the edit button above. Don't post comments or ask a new question, editing will automatically queue it for reopening review. $\endgroup$ Nov 28, 2023 at 11:08
  • 1
    $\begingroup$ Yes, a file might help or at least some screenshots of how it looks and the settings etc. There are so many possibilities, starting with objects having different settings for viewport and render, being visible or invisible in viewport and render and so on that simply saying, the render is too dark and you've "tried everything" is not really a good starting point for troubleshooting on our side. $\endgroup$ Nov 28, 2023 at 11:11
  • $\begingroup$ I added some more info, if anyone needs a screen shot of any particular settings just ask and if anyone wants me to share blender file it would be cool if you told me how to and I'll do it $\endgroup$ Nov 28, 2023 at 11:55
  • $\begingroup$ Hello and welcome. Did you actually add an HDRI to your world nodes or are you using the build in HDRIs? Also, try this blender.stackexchange.com/questions/200646/… $\endgroup$
    – Emir
    Nov 28, 2023 at 14:11
  • $\begingroup$ Oh my god the answer was so simple such a rookie mistake thank you so much it works now!! $\endgroup$ Nov 29, 2023 at 6:18

0

You must log in to answer this question.

Browse other questions tagged .