0
$\begingroup$

I did this a while back, so most of my knowledge of blender has gone out the window. When I render my image the object is no loses its material from that's visible from viewport shading. Any idea how to fix this? My "material" actually doesn't seem to be showing either. enter image description here

$\endgroup$
1
  • $\begingroup$ I think Falk is right, check the Viewport Shading panel, you must have disabled the World option, when it renders it uses your current wordl settings but you probably don't have any HDRI image to reflect $\endgroup$
    – moonboots
    Nov 26, 2023 at 7:51

1 Answer 1

1
$\begingroup$

It looks to me that Viewport Shading doesn't use the Scene World which is used when rendering. Can you verify this by checking the dropdown menu next to the shading type icons in the upper right corner (shown in the screenshot below)?

Viewport Shading dropdown

If Scene World is unchecked as I expect, you will need to use the same HDRI shown there as the background in the scene world or config it as you wish. To add an HDRI background to the world:

  1. In a Shader Editor, switch the Shader Type to World.
  2. Add an Environment Texture node, and connect to the Background node.
  3. Open the desired HDRI. The HDRIs that come with Blender are stored under /{blender_folder}/{blender_version}/datafiles/studiolights/world/.

Refer to the screenshot below for more information.

World

If I am wrong, maybe it's because there is an issue with the shader, but try the above first...

$\endgroup$
1
  • $\begingroup$ Thank you @falk. This helped! $\endgroup$
    – Jeremy
    Nov 26, 2023 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .