1
$\begingroup$

When I click the transparency under film render properties it shows transparent in the viewport, but when I render an image it shows a black background instead of transparent.

Particles render fine and the animation I have also renders fine. The only problem I have is the background not being transparent in the render. I tried changing the output properties to PNG format and RGBA and rendering as images, but it does not fix the problem.

Viewport:
viewport

Render:
enter image description here

I'm using Eevee renderer.

Here is my file: https://drive.google.com/file/d/1nqAhWD9VREQj-J9e9L7mawKdia61NRy0/view?usp=sharing

$\endgroup$
3
  • 1
    $\begingroup$ pls provide blend file because we cannot see any important settings you made. thx. $\endgroup$
    – Chris
    Nov 23, 2023 at 6:33
  • 1
    $\begingroup$ Hello are your sure that you don't have objects that are hidden for preview but enabled for render? check the Outliner... $\endgroup$
    – moonboots
    Nov 23, 2023 at 6:55
  • $\begingroup$ Thank you for taking the time to upload your file. However, the file is +300MB, it's HUGE for what - according to your screenshots - should only be particles in a vacuum, that's no more than 1MB tops. Even with an above average network, it takes almost a minute to download 300MB, I won't even guess how long it takes for other people. For next time, please read How to upload a blend file on BSE - good practices and advice - Blender Meta Stack Exchange so to save yourself and others some time and frustrations ;) $\endgroup$
    – L0Lock
    Nov 23, 2023 at 16:25

1 Answer 1

0
$\begingroup$

There's an object called Limit that is disabled for preview but enabled for render, disable it for render if you don't want it to mask the transparency. Also disable the Output > Post Processing > Sequencer option otherwise the movie in your Video Sequencer will be rendered instead of your scene. At last enable the Render > Film > Transparent option.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .