Link to video https://imgur.com/a/41qLROy

I've tried hitting Alt H, I've tried opening in version 3.6 instead, but no matter what i do this happens. When I switch to textured or weighted paint modes the select

  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$
    – quellenform
    Nov 21 at 0:22
  • $\begingroup$ Hello could you please share your file? $\endgroup$
    – moonboots
    Nov 21 at 8:38

1 Answer 1


I think you may have toggled X-Ray by mistake. Try to toggle it off and see if that fixes the issue.


This could be an issue with the Viewport Shading Settings. Try to press the button marked in the screenshot below, and tweak the settings.

Viewport Shading Settings

After examining the model, it turned out that the model has most but not all of its geometry hidden in Edit Mode. In modes that display only faces including Texture Paint, nothing shows up. However, in Edit Mode, the remaining geometry gives the impression that the geometry is not hidden.

The fix is simply to press Alt + H while in Edit Mode. If you switch to Texture Paint afterwards, you will see all the faces again. I attached screenshots below that show the steps.

This is how the model looks like now in Texture Paint. Texture Paint Before

This is how it looks like in Edit Mode. Edit Mode Before

This is how it will look like in Edit Mode after pressing Alt + H. Edit Mode After

This is how it will look like in Texture Paint. Texture Paint After

  • $\begingroup$ Still not showing up. Thanks for your reply! here's what happens now, it looks like the mesh is still there in wireframe so I'm very confused imgur.com/a/JoMUi3y $\endgroup$ Nov 21 at 1:06
  • $\begingroup$ @ZachSheram I attached another screenshot to my answer. Can you share the settings you get by clicking that button. $\endgroup$
    – Mr A
    Nov 21 at 10:36
  • $\begingroup$ thank you for your kindness and help, do you see the issue here? imgur.com/a/uKt19qC $\endgroup$ Nov 21 at 20:45
  • $\begingroup$ There doesn't seem to be any issues there too. This could be a bug with the new Blender version. If it's okay to share the file, I will be able to dig a bit deeper to try to figure out the issue. $\endgroup$
    – Mr A
    Nov 21 at 22:07
  • $\begingroup$ Yeah i thought it might be a 4.0 bug, but the same issue persists in 3.6. not sure how to link the file here, but I posted it on this forum blenderartists.org/t/… $\endgroup$ Nov 21 at 22:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .