0
$\begingroup$

using Blender 4.0

This is how I created the circle:

pressed on Shift + A keys in the opened menu selected Mesh > Circle.

to move the circle up only one axis only up I first selecting the circle by just clicking on the circle then pressed on G after that pressing the axis, I want it to move on so in this case Z then just moving the mouse up down and to keep the circle in that position click on the mouse left button.

now while the circle is selected, I pressed the TAB key to enter the edit mode and it's showing me all the vertices of the circle.

circle all vertices selected

now to add more vertices I clicked on the mouse right button and in the opened menu I selected Subdivide few times to add as many as I need more vertices to the circle.

circle with more vertices

next I did is pressed the A key to select all vertices then pressed W key and in the opened menu clicked on Subdivide many times.

now I want to export it and use in unity3d:

I clicked in the menu on Mesh > Notrmals > Recalculate Outside

what it does is open a window in the bottom name > Recalculate Normal if I expand the arrow there is a checkbox inside say Inside.

that's it.

then in the menu I did: File > Export > FBX (.fbx) gave it a name and export it.

I dragged the new created file to my unity3d editor and then to the hierarchy but no circle and in most of the cases I'm getting warning:

Can't calculate tangents, because mesh 'Circle' doesn't contain normals. and in some cases that it didn't show the warning still it didn't show the circle.

what am I doing wrong ?

$\endgroup$
2

1 Answer 1

0
$\begingroup$

If you create the circle this way, it will not have any faces. I don't think Unity will render edges by default. You need to add polygons.

After adding the circle, press F9 to adjust the operator settings, and set the Fill Type to Triangle Fan. You can optionally increase the number of Vertices here instead of subdividing the circle afterwards.

Circle

The tangents warning has nothing to do with the circle not showing up. I think you need custom normals for that which can be added in different ways. The easiest is to run Mesh > Normals > Reset Vectors or Mesh > Normals > Smooth Vectors in Edit Mode with everything selected.

$\endgroup$
2
  • $\begingroup$ there is no reset normals in edit mode. I did Mesh > Normals but no reset normals. and no matter how many times I make Mesh > Normals > recalculate outside in unity it keep showing that there is no normals. Can't calculate tangents, because mesh 'Circle' doesn't contain normals. $\endgroup$
    – Daniel Lip
    Nov 20, 2023 at 21:25
  • $\begingroup$ @Jack Sorry, that was a typo. I meant Reset Vectors. I will fix it in my answer. Try that or Smooth Vectors, and check if it makes a difference. $\endgroup$
    – Mr A
    Nov 20, 2023 at 21:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .