1
$\begingroup$

I did not find the gltf options under File/Import or File/Export menu in blender 4.0.1 (linux). Looking into the add-ons I tried to enable the add-on named Import-Export: glTF 2.0 format. It fails and logs the following error:

Traceback (most recent call last):
  File "/usr/share/blender/4.0/scripts/modules/addon_utils.py", line 401, in enable
    mod.register()
  File "/usr/share/blender/4.0/scripts/addons/io_scene_gltf2/__init__.py", line 1661, in register
    blender_ui.register()
  File "/usr/share/blender/4.0/scripts/addons/io_scene_gltf2/blender/com/gltf2_blender_ui.py", line 521, in register
    bpy.types.NODE_MT_category_SH_NEW_OUTPUT.append(add_gltf_settings_to_menu)
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
AttributeError: 'module' object has no attribute 'NODE_MT_category_SH_NEW_OUTPUT'

Is there something I'm doing wrong here ?

$\endgroup$
3
  • $\begingroup$ I'm running Windows here, but usually that built-in addon is enabled by default as far as I know. If you click the down arrow against that addon in the Addon preferences, what version number does it show? - Should be 4.0.44. $\endgroup$
    – John Eason
    Nov 20 at 21:59
  • $\begingroup$ It's 3.6.6 for some reason $\endgroup$
    – monsieur_h
    Nov 22 at 9:20
  • $\begingroup$ I'd expect it to be the same version as the Windows download. The addon version included with Blender 3.6.5 is 3.6.28 so it looks as if your one hasn't been updated to comply with the Blender 4 APIs. See the answer below! $\endgroup$
    – John Eason
    Nov 22 at 9:34

1 Answer 1

0
$\begingroup$

This issue is fixed in the arch package now; Run a system update to resolve this issue.


Previous answer, kept here as it may inspire workarounds for similar issues:

In short, install the compatible version of the plugin from github.

In long:

You'll need git installed.

Find where the gltf plugin is kept. On my system this was /usr/share/blender/4.0/scripts/addons/io_scene_gltf2

Delete (or move to a safe location) that folder. You may need permissions.

Clone the git repo

$ cd ~
$ git clone https://github.com/KhronosGroup/glTF-Blender-IO.git

Checkout the release branch for your blender version

$ cd glTF-Blender-IO
$ git checkout blender-v4.0-release

then copy the addon folder to where you found the old version

$ cp -r ~/glTF-Blender-IO/addons/io_scene_gltf2 /usr/share/blender/4.0/scripts/addons

In blender, open preferences > addons, refresh the list and check if the new version has installed.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .