0
$\begingroup$

I just use modifier boolean and it brake my render, idk why.

Link to file https://mega.nz/file/UiN3mIiI#2amb61yz-1j7d43prSwPikVC_aZ4DHoFfJAlVLNaPrk

model in layout

model in render

modifiers in invisible part in render

$\endgroup$
5
  • 1
    $\begingroup$ Mirror modifiers after booleans before mirror modifiers are usually applying on a non-manifold mesh and that doesn't normally work. Try putting it after. It's likely not showing in the render because the normals are inverted $\endgroup$
    – Cornivius
    Commented Nov 20, 2023 at 20:16
  • $\begingroup$ the modifier stack seems weird but please share your file so that we can take a look $\endgroup$
    – moonboots
    Commented Nov 21, 2023 at 8:43
  • $\begingroup$ @moonboots add link to my file, check if you can pls $\endgroup$
    – LeCras
    Commented Nov 27, 2023 at 19:20
  • $\begingroup$ You generally put the Boolean modifiers before the Subdivision Surface, also only use Boolean if this is necessary because it tends to mess the topology, so maybe try to model your gun without Boolean if you can avoid it $\endgroup$
    – moonboots
    Commented Nov 27, 2023 at 19:33
  • $\begingroup$ @moonboots Thank you, i will try to do it without booleans, i just dontn know how to do it by another way. Its just my first time using blender. Thanks $\endgroup$
    – LeCras
    Commented Nov 27, 2023 at 19:48

1 Answer 1

0
$\begingroup$

If you use different subdivision levels for the Render, whatever you see in the Viewport may not match what you see in the Render.

If the problem still persists after equating the subdivision levels, try the Exact Solver. Also, try to enable Self Intersection and/or Hole Tolerant under Solver Options.

Boolean Modifier


Update: I downloaded the file, and for each Subdivision modifier on each object, I set the Render Levels (marked red in the screenshot below) to the same value as the Viewport Levels (the number right above it), and that fixed the problem.

Subdivision

A test render is attached below.

Test

$\endgroup$
2
  • $\begingroup$ Thanks, but i cant solve it by this way, but i click to "Apply"(Ctrl+A) in modifier(subdivision) and part of gun appear. Sorry if i miss smth im newbie $\endgroup$
    – LeCras
    Commented Nov 27, 2023 at 18:52
  • $\begingroup$ I updated my answer with screenshots. Please check it out. $\endgroup$
    – Mr A
    Commented Nov 27, 2023 at 20:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .