0
$\begingroup$

I want to animate a shader node from a sound file (showing an open or closed mouth if the sound crosses a threshold). I follow the suggestions here, here and here, but the graph editor shows nothing in the result. I tried with a WAV and an MP3 file. Here is a GIF showing my process:

screencast of baking sound to f-curves

I'm new to Blender, and the threads above suggest this feature works out-of-the-box, so I'm sure I'm doing something wrong, but what is it?

Update after HOME key

Following one answer, I press the HOME key after baking the sound. Baking had some result, as the editor zooms out and shows crosses at the expected length (24 frames per second times length of the track), but it does not show a curve. I also pressed the "Normalize" button at the top left:

screenshot after HOME and Normalize

The track has synthetic speech at about -16 dB. You can find it here. And I confirm that it has audio, as in this screenshot from Audacity:

enter image description here

I also tried with a different track, a longer one in MP3, and the result is the same.

Second update

It seems that all the steps are correct and it may be my Blender version that is faulty. Here is a file started from scratch.

$\endgroup$

1 Answer 1

2
$\begingroup$

You're doing everything correctly, and the operator works fine. You just need to press the Home key to zoom out and see the entirety of the baked curve. It's normal for a sound file to start with silence, so you won't see audio fluctuations at the default current zoom level.


Audio File Test

I was able to bake the sound to an F-curve. A screenshot is attached below. I tested in version 3.6.0 and 4.0 (the operator name was changed to Sound to Samples).

Test

The steps I followed are:

  1. Open Blender and switch to the Animation Workspace.
  2. Select the Cube and add a Location Keyframe.
  3. Switch the Dope Sheet to a Graph Editor.
  4. Run Channel > Bake Sound to F-Curves and select the sound file.
  5. Press the Home key.

Screenshots from the shared file

1

2

$\endgroup$
8
  • $\begingroup$ Thank you! It still failed and I added an update. Shall I upload the Blender file to see if it's some error other than user error? $\endgroup$ Nov 23, 2023 at 9:33
  • 1
    $\begingroup$ @miguelmorin I am more suspicious of the audio file. Can you verify that it has audio? I can try it on my side if you can share it. One thing you can try is to press the Normalize button on the top left of your second screenshot. It will switch to an alternative view that fits the graph into the 0 to 1 range, so even if the audio is very quiet, it should show something. If it doesn't, then there is probably no audio, and you should try the file in an audio player to verify. $\endgroup$
    – Mr A
    Nov 23, 2023 at 10:00
  • 1
    $\begingroup$ @miguelmorin I updated my answer with the steps I followed to test the sound file. It works as expected for me. Please follow the same steps in a new blend file to verify that everything works. $\endgroup$
    – Mr A
    Nov 23, 2023 at 13:00
  • 1
    $\begingroup$ I opened the file, and the baked curve was there. I attached screenshots to my answer. I don't know what could be the source of this issue, but a fresh install could help us figure it out. Can you also try to lower the threshold of your setup to below 0.3? As you can see from my second screenshot, the audio doesn't go past 0.35. $\endgroup$
    – Mr A
    Nov 24, 2023 at 21:41
  • 1
    $\begingroup$ You're welcome! That's great to hear. I wish you the best in your project. $\endgroup$
    – Mr A
    Nov 27, 2023 at 18:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .