3
$\begingroup$

I want to hide the red reflection as shown in the image below. I achieved this in Eevee, and I want to do it in Cycles because it looks more realistic in Cycles. I've tried adjusting light path settings like glossy and diffuse, as well as all blend modes and screen space reflections, but it's not working.

https://drive.google.com/file/d/1DDNB0hsYgwc599h7QR7H5V7gyV2DL4ls/view?usp=sharing

enter image description here

enter image description here

$\endgroup$
7
  • $\begingroup$ Hello what causes the red reflection? Maybe share your file? Don't forget to pack your images $\endgroup$
    – moonboots
    Nov 18, 2023 at 9:05
  • 1
    $\begingroup$ We really can't help you if we're not given any clue about red things in your scene.. are you saying there are none, and this is a complete mystery? $\endgroup$
    – Robin Betts
    Nov 18, 2023 at 9:08
  • $\begingroup$ check link @moonboots $\endgroup$ Nov 18, 2023 at 9:44
  • 1
    $\begingroup$ Is it possible to turn off the reflection setting so that it does not reflect like in the upper image @moonboots $\endgroup$ Nov 18, 2023 at 10:27
  • 1
    $\begingroup$ Yes because in Eevee by default you won't have any reflection of the objects that are in the scene $\endgroup$
    – moonboots
    Nov 18, 2023 at 10:33

2 Answers 2

5
$\begingroup$

enter image description here

If you are looking how to eliminate reflection of object in its surface at all like in Eevee try this ...

enter image description here enter image description here

... or you can go to Object Properties > Visibility > Ray Visibility and uncheck Glossy.

enter image description here

If you need to uncheck Glossy for more objects at once select all participating objects and uncheck Glossy. By hovering over checkbox right click and choose from contextual menu Copy to Selected.

enter image description here


Note: Keep in mind ... by "cropping" the real behaviour of path traycing from render you devaluate realism of Cycles, that you choose for. So you lost all benefits of realism and just increase a render time :)

$\endgroup$
1
  • $\begingroup$ You are probably experiencing reflection of other objects ... so do the same for light object ... or uncheck Glossy in Object Properties > Visibility > Ray Visibility ... btw I just noticed you can plug Reflection ray directly to Mix Factor (World shader is still reflecting). $\endgroup$
    – vklidu
    Nov 18, 2023 at 11:52
2
$\begingroup$

You could use the Is Glossy Ray output of an Input > Light Path as factor between your current material and a Glossy that is white:

enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks, buddy, it was greatly helpful @moonboots $\endgroup$ Nov 19, 2023 at 6:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .