1
$\begingroup$

There's a lot of questions about this but they're really old and no one seems to mention the issue I'm running into. Here's a screenshot of this test scene I'm using to debug (Blender 4.0, using Filmic color transform, not Agx) enter image description here

So I'm using the following nodes to composite glare and include the glare in the alpha. The viewer is showing the alpha to show it seems to be working enter image description here

I'm exporting in EXR as explained here and I'm bringing it into Davinci Resolve. And everything looks good. I'm adding the filmic transforms from this tutorial to get it looking closer to Blender. Not quite right, but I figure I can tweak the colors and such. enter image description here

However, if I put a solid color underneath, I'm seeing some weird behavior. It's like the brightest spots are being made darker or something. This is a pure white layer underneath enter image description here

I can't for the life of me figure out why it would do this, and if this is a Blender issue or a Resolve issue. All those areas that became red and black are not transparent so a white layer underneath shouldn't change their color. I would expect it all to just be white

This is with a color ramp below enter image description here

Any help or ideas for this would be appreciated. Am I doing the compositing nodes wrong? Is this just not possible?

$\endgroup$
5
  • 1
    $\begingroup$ Answered correctly hundreds of times here. The issue is the alpha encoding. It must be encoded as associated alpha, and decoded in the target application as associated alpha. Unassociated (suboptimal term “straight”) alpha cannot encode tristimulus without occlusion. No PNGs or other 8 bit encodings. Must be EXR and form the picture in Resolve using the same picture formations. $\endgroup$
    – troy_s
    Nov 17, 2023 at 16:18
  • $\begingroup$ I'm pretty sure I'm encoding the alpha as associated. I'm not sure how to adjust that setting when saving as EXR, but the alpha part seems to be handled fine as you can see from the images. Resolve imports as associated by default (it calls it "premultiplied"). The problem is actually the non-transparent parts of the image changing color based on the layer below which is strange. I tried importing my image into Blender's video editing tools and interesting it seems to work fine there, so this may just be more of a Resolve issue $\endgroup$
    – Naty722
    Nov 20, 2023 at 20:04
  • $\begingroup$ Blender is incapable of encoding the proper alpha to anything other than EXR. A dumb design decision made a long time ago, that needs to be changed. Try the composite with EXRs and you won’t have any issues. Getting to Resolve is another matter entirely. $\endgroup$
    – troy_s
    Nov 20, 2023 at 20:59
  • $\begingroup$ As I mentioned in my post, I've been exporting with EXRs. It must be a Resolve issue that only crops up when there's any alpha $\endgroup$
    – Naty722
    Nov 20, 2023 at 23:29
  • $\begingroup$ It could be that Resolve does a classic Adobe and mangles the alpha. Does the problem exist in ResFusion if you do a composite within the ResFusion node chain? It’s a bit tricky to get to uniform colourimetry last I looked within ResFusion, but it should work. I believe the ingestion will encode it to something intermediate for the timeline, so you have to decode and re-encode at the head and tail. $\endgroup$
    – troy_s
    Nov 21, 2023 at 21:49

0

You must log in to answer this question.

Browse other questions tagged .