1
$\begingroup$

New to blender and have been digging into a lot of tutorials and trying to learn more about shaders and how they interact. I have a neon-like flicker effect on some text which is working well when the neon is on, but when the neon effect is off, it's leaving the curves black, which I would like to control better.

Steps to recreate - I created 3 text objects (osrius the - bear - pally), turned them into curves, extruded 0.01m and beveled 0.005m. The idea was to create round-ish tubes to be similar to neon (this may be where the issue is?) - When I add the neon flicker effect it looks like the first photo below, all of the colors are right, good emission and the flicker works as expected.

When the flicker effect is off - the curves are just sitting there black and I can't figure out how to control or change that (2nd image). I've placed them in a scene and rendered out a couple of rough drafts for animation timing, hoping they were just view window outlines, but that was a little too hopeful. I would like to figure out how to effect change to the off state of the neon effect. The ideal would be a semi transparent state, or just invisible when the neon is off. Any advice on where to start looking for the answer, a tutorial to look into, or an answer would be super helpful.

enter image description here

enter image description here

$\endgroup$
1
  • $\begingroup$ You probably hit a value that was mapped to 0 in this specific case. If you don't want to have completely black values set the To Min in your Map Range node to a higher than 0 value - like 0.1. $\endgroup$ Nov 17, 2023 at 9:03

2 Answers 2

0
$\begingroup$

You could mix your Emission node with a Glass node, or with a mix between a Transparent and a Glossy node (you could even mix Glass, Transparent and Glossy), then keyframe the Mix Shader to switch from emission to transparent. Note that if you use Eevee you'll need to tweak some settings if you use glass or transparency:

enter image description here

$\endgroup$
0
$\begingroup$

Thanks for all of the help!

I was able to get something working with some of the suggestions here. What I needed to change were a couple of connections and blending modes.

1/ some of the objects were set to opaque and not alpha blend (duh moment) 2/ I needed to connect the flicker generator result to the mix shader fac input. My understanding it that this tells the mix shader the state that should be shown as well as tells the emission node the strength. I may have just stumbled on a happy accident that works because of the circumstances and not really a viable long term solution. Not sure at my current skill level.

One side effect I'm working to mitigate now is that even though the text is in the same x plane as the main subject, the camera isn't treating it as in the same plane, so with a shallow depth of field the text is far out of focus for some reason I haven't worked out yet. Going to try a couple different things and see if maybe it doesn't need to be fully transparent since this is a learning project and not something super polished.

New material nodes look like the below. enter image description here

$\endgroup$
1
  • $\begingroup$ Changing from Alpha Blend to Alpha Clip seems to have resolved the camera focus issue $\endgroup$ Nov 18, 2023 at 22:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .