3
$\begingroup$

I have this mesh and I did a grid filling. I converted quads to tris but why do I have quad faces left, upper left face for example? plane mesh
quads to tris

$\endgroup$
  • 1
    $\begingroup$ Which method of converting did you use? For example, if using Triangulate Faces with Ctrl + T while in Edit mode, the result will look much clearer - i.imgur.com/jlihyeW.jpg $\endgroup$ – Mr Zak May 6 '15 at 15:33
  • $\begingroup$ I used Triangulate Faces with Ctrl + T while in Edit mode. The problem is the grid filling method (bar space -> grid fill while in Edit mode), because I have this [grid fill] (imageshack.com/i/hlvHZoh6p) when I apply grid filling method on the mesh of the first image before converting quads to tris. And it seems you used a grid mesh ? Not a mesh like the first image, without faces. $\endgroup$ – Chaton May 6 '15 at 18:02
1
$\begingroup$

I did the same thing shown in the images above and it looked fine to me but when I went through the Triangulate options, I found that one of the possible settings combinations did produce the results you showed.

Here are both results shown with the settings. The dialogue box that you see in the images can be accessed by using F6

enter image description here

enter image description here

If you activate Vertex Selection mode and drag out the extra vertex that is seen, what's really happening can be seen. The model is triangulated properly but the algorithm failed to lay out the geometry properly. Here is an animation showing this.

enter image description here

You could file a bug report if you like. https://developer.blender.org/

Personally I'd prefer to locate Ideasman42 and provide him with a link to this page so he can put some thought into this when he's not working on new tools or fixing bigger problems.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.