I have noticed a difference between the calculation of the thickness of a solid using the related Mesh Analysis tool and the thickness value of the same solid measured with the digital ruler, as you can see in the picture here below.

What is the reason for this difference? As far as I can understand and verify with printed products, the effective thickness of the solid is the one measured with the ruler; do you agree with that?

Thickness value measured with the Mesh Analysis tool and digital ruler. Sometimes happens this - the thickness values calculated though the edge length and through the Mesh Analysis do not match

Measuring with the ruler and with the automatic tool for edges shall return the same result if the right projection is applied

  • $\begingroup$ Hello and welcome. Your title states that the scale was applied, but your screenshot shows otherwise. Could you clarify? $\endgroup$ Nov 14 at 9:30
  • $\begingroup$ Please refer to this: blender.stackexchange.com/questions/304771/…. Applying the scale has not solved the issue. $\endgroup$
    – user176704
    Nov 14 at 10:19
  • $\begingroup$ Hey. Please don't scatter information about your issue across different posts, it is much harder to follow and keep track of. Also please don't post the same question more than once. If you feel your question was incorrectly marked as duplicate, or the linked posts don't adequately address your issue, use the Edit button above, and include information of what you have tried, why it failed and how the duplicates don't address your issue. Once edited the question is automatically queued up for review so it can be reopened. $\endgroup$ Nov 14 at 10:31
  • $\begingroup$ Show a screenshot of your object scale applied, and the modifier stack showing how different modifiers may be affecting your object. Otherwise diagnosing by blind guesses is an unnecessary trial and error process $\endgroup$ Nov 14 at 10:32
  • $\begingroup$ I have already written you that the scale factors are blocked in this example. Please read the second post about this subject and watch the second image attached to it. $\endgroup$
    – user176704
    Nov 15 at 11:10

1 Answer 1


What is the reason for this difference?

If you examine the Thickness Mesh Analysis tool, you will see that it include a samples slider. This means that it uses samples to calculate the thickness. Sadly, it has a hard limit of 32 samples which doesn't produce very accurate results. However, I think the reason the values are not accurate is because it seems to cast rays in different directions and averages the thickness. If one or more of these rays end up somewhat parallel to the surface, they will cause the measurement to be inflated. Maybe, the minimum of the samples should be chosen, but please note this is just my guess. I didn't check the source code.

Thickness Mesh Analysis tool

On the other hand, the measurements obtained with the Measure tool are typically correctly placed by the user to measure the minimum thickness which tends to be along the surface normal. And this explains why the tool does the sampling approach, because the minimum thickness is not always going to be along the normal, so the tool has to look around, in a sense.

As far as I can understand and verify with printed products, the effective thickness of the solid is the one measured with the ruler; do you agree with that?

I agree. Whatever you measure is definitely real and should match what you measure digitally with the Measure tool as long as both measurements are carried out along the same direction at the same spot.

I typically use the Analysis Tools to figure out possible problematic areas, and then manually verify that they are okay with the Measure tool. The Thickness Analysis Tool tends to falsely mark edges of printed pieces.

  • $\begingroup$ Dear Mr A, Thank you for your answer; I sincerely appreciate your explanation. Should you need any help, please don't hesitate to contact me. $\endgroup$
    – user176704
    Nov 23 at 10:39
  • $\begingroup$ You're welcome! $\endgroup$
    – Mr A
    Nov 23 at 10:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .