2
$\begingroup$

So I followed Andrew Price's tutorial on making a realistic floor using bump maps, displacement maps, etc. I did it, everything turned out great, until I actually played my animation.
My cubes that were sitting happily on the floor violently exploded. I realized that I had to move the cube quite a bit above the plane so it would sit nicely on it without exploding. cubes and floor plane Here's all the nodes and stuff

cycles material nodes

Is there a way I can get the cubes to sit on the floor without exploding? Looks pretty weird just floating in the air like that. rendered cubes, floor and wreaking ball

$\endgroup$
1
  • 2
    $\begingroup$ Is it possible you could upload your .blend? $\endgroup$
    – gandalf3
    May 6 '15 at 5:27
2
$\begingroup$

One easy solution is to add another plane which will be use only for collisions.

  1. Turn off the rigid body on the floor you have now.
  2. Add a new plane, and position it so that it is at (or sightly below) the top of the bumps on your original floor.
  3. Add passive rigid body physics to the new plane.
  4. Disable render of the collision only plane, by unticking the camera icon for it in the Outliner.
    restrict render in the outliner
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.