2
$\begingroup$

I am a complete Blender noob. I am editing a simple video (no 3D objects) and I am trying to apply the same transformation to multiple images at once. However, I can't select and apply to multiple.

system info:

version: 3.5.1, branch: blender-v3.5-release, commit date: 2023-04-24 18:11, hash: e1ccd9d4a1d3, type: release
build date: 2023-04-24, 23:31:15
platform: 'Linux-6.2.0-36-generic-x86_64-with-glibc2.35'
binary path: '/home/foo/Desktop/blender-3.5.1-linux-x64/blender'
build cflags:  -Wall -Werror=implicit-function-declaration -Werror=return-type -Werror=vla -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wlogical-op -Wundef -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Wformat-signedness -Wrestrict -Wno-stringop-overread -Wno-stringop-overflow -Wnonnull -Wabsolute-value -Wuninitialized -Wredundant-decls -Wshadow -Wno-error=unused-but-set-variable -Wimplicit-fallthrough=5  -std=gnu11 -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -ffp-contract=off -msse2  
build cxxflags:  -Wuninitialized -Wredundant-decls -Wall -Wno-invalid-offsetof -Wno-sign-compare -Wlogical-op -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Werror=return-type -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wundef -Wformat-signedness -Wrestrict -Wno-suggest-override -Wuninitialized -Wno-stringop-overread -Wno-stringop-overflow -Wundef -Wmissing-declarations -Wimplicit-fallthrough=5  -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -ffp-contract=off -msse2  
build linkflags:  -Wl,--version-script='/home/blender/git/blender-v350/blender.git/source/creator/symbols_unix.map'
build system: CMake
windowing environment: 'X11'

Steps I followed:

  1. go to video editing go to video editing

  2. Add image

Add image

  1. select image

select image

  1. repeat until I add 3 images

3 images added

  1. Put images in a single channel

Put images in a single channel

  1. before applying transformation to single image

before applying transformation to single image

  1. after applying transformation to single image (the green bullets show the transformations I applied)

after applying transformation to single image

I expected that if multiple images were selected and I would edit the transformations the transformation would be applied to all the selected images. However this is not happening

  1. select multiple images

select multiple images

  1. but transformation is only applied to the image (object in the video editor) with the white contour, not the orange ones

transformation is only applied to the image with white contour

Edit: added Blender system info

$\endgroup$

2 Answers 2

4
$\begingroup$

In almost all parts of Blender, entering a value in a field only changes the value of the active object of which the value is shown in that field.

There are two mostly common ways to change them together if you have multiple objects selected:

  1. Hold Alt while you click into the field to change a value. This way all selected objects will get this same value in the according field. //Edit: According to the comments, it seems you have to use Alt+Shift and click on Ubuntu. By the way, holding Alt to change multiple objects also works if you are scrolling a slider to change the value. But then it will change by the same amount, not end in the same value and work like method 2 below.

or

  1. Click into the field, enter a value, then press Alt+Return to confirm it. This way, the values in the other fields will be changed by the same amount.

Examples: Let's say, (active) object1 has a value of 2.0 and another object2 has a value of 3.0 in a field you want to change.

Method 1: Changing the value to 2.5 will make it 2.5 for both.

Method 2: Changing the value to 2.5 will make it 3.5 on object2.

On objects where they all share the same value, those methods won't make a difference and it does not matter which one you choose. Having different values however will result in different values in method 2.

The change in method 2 is in absolute values, not relative, i.e. if you have the values 1 and 3, doubling the 1 so you have 2 will not double the 3 to 6, it only adds the difference so you get 4.

$\endgroup$
8
  • 1
    $\begingroup$ Thanks a lot! Method 2 worked out of the box. For method 1, since I am on Ubuntu I had to use Alt + Shift + click blender.stackexchange.com/a/119873/176564 $\endgroup$
    – vkats
    Nov 10, 2023 at 9:05
  • 1
    $\begingroup$ I didn't know you could do that (especially not the 'relative' change) - very nice! $\endgroup$ Nov 10, 2023 at 9:05
  • $\begingroup$ @RichSedman Dangerously enough I've seen YT tutorials where the tutors teach people the second method but explaining you could do this to make all values the same - the problem is, this all just worked "by accident" in their tutorials because the selected objects had no differing values which makes it result similar to the first method. $\endgroup$ Nov 10, 2023 at 9:18
  • $\begingroup$ @vkats Oh, good to know - I'll add this in the answer for future users using Ubuntu. $\endgroup$ Nov 10, 2023 at 9:21
  • $\begingroup$ I've just tried method 1 with a couple of rotated cubes and it seems to be 'relative' whatever I do. $\endgroup$ Nov 10, 2023 at 9:25
3
$\begingroup$

Throughout Blender, if you have multiple "objects" selected (and one is the 'active' "objects"), changing the properties only affects the 'active' one (the white bordered one in your case). However, right-clicking the property should bring up a menu include a 'Copy to Selected' option. Selecting this option will propagate that setting to all of the other 'Selected' ones.

$\endgroup$
1
  • 1
    $\begingroup$ oh! that works too, thanks for sharing that tip $\endgroup$
    – vkats
    Nov 10, 2023 at 9:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .