0
$\begingroup$

I wanted to add a line art modifier to the chara. When I add the line art, the moment when you put the default material into the Material box, it freeze indefinitely and then crash. The problem being highly related to the folliage instancer (explained bellow).

here the desired lineart style (it came from another scene)

the render I'm talking about

Scene content

I have a scene [pic above] with foliage made with particle system then converted into mesh and cleaned [pictures at the end of the paragraphe]. This system is duplicated so I can make an outline of this blob of ico-spheres with the solidify modifier. Then the collection containing these two mesh are instanced to make bigger tree (so technically they don't matter in the render) The log is made out with the Sappling Tree Gen integrated addon, also converted to mesh, cleaned and duplicate to add the Solidify modifier too.

  • stats of the mesh/particles emitter stats of the mesh/particles emitter

Inside the mesh of the mash/particles emitter inside the mesh of the mash/particles emitter

Outliner so you have the names outliner so you have the names

The shaders are very simple, there's nothing fancy [pic just bellow] and all of the other shaders are basicaly alike (but without math node though) shader editor

The line art works on another scene with just the charas. On my current scene when I exclude from view layer all the other props exept the chara, it works (so I guess it's not corrupted). I tried to include them back one by one and it cease working when I show back the folliage instancer (on the pics above).

Rendering with Freestyle works the same and I have absolutely no control over it. Here is a pic with the previously particle system (now a mesh) disable in render. When rendering either with 'feuillage' or 'foliage instance' the render gets stuck at 98%.

freestyle moche

The question

Why it doesn't work, even after cleaning the intersecting mesh of 'feuillage' (it goes to 276000 vertices to almost 63000). Further knowing that I'm not adding line art on this mesh at all... When adding Grease Pencil, in the task manager, Blender take up almost all processor and memory and the PC fans run loudly.

PC specs

AMD Ryzen 5 7600 6-Core (with a Noctua NH U12S fan)
32Go of RAM
NVIDIA GeForce RTX 3060
64bit system
Windows 11 (insider beta canal currently on built 22635.2700 ni_release)

Blender specs

Blender 3.6.5 (steam version)⠀⠀+⠀⠀Blender 3.6.3 (website version), none of them worked EEVEE rendering

It's for a project trying to mimick the Ukiyo-e style so line-art is very important and except grease pencil, I don't see any other neat and light outline solution for animated props. So if you have any other solution involving an other line-art method I'd be happy to hear them !

$\endgroup$
3
  • $\begingroup$ Please add your images directly into your question rather than just adding links to them. No one is going to click on every link in your text to see the images. $\endgroup$
    – John Eason
    Nov 9, 2023 at 14:27
  • $\begingroup$ thank you for the recomendation ! I hope it's better now :) $\endgroup$ Nov 9, 2023 at 15:07
  • $\begingroup$ Yes. Much better thanks. Hopefully someone here familiar with grease pencil will be able to help. $\endgroup$
    – John Eason
    Nov 9, 2023 at 15:51

0

You must log in to answer this question.