0
$\begingroup$

Essentially, the state color does not change to orange when a transformation is made to bones in my armature, which makes it difficult for me to keep track of which transforms have had a keyframe added or replaced. For example:

  1. A humble bone for IK posing at a time when it does not have any keyframes:

  2. That same bone has been moved from its initial position, is still without keyframes, yet the state color for the transforms remains green rather than orange as though nothing has been changed

  3. A keyframe for the previous location has been created, and the state color has turned to yellow as it should, yet moving the bone again (without replacing the keyframe) still does not change the state color to orange

This behavior is exclusive to this armature; other armatures in this project and others do not suffer from it. Because of this, I assume that there must be a setting somewhere for this particular armature that is causing this behavior, but none of them appear to have an effect. I am at a loss for what could be the source of the problem and would rather Blender notify me whether or not properties have been saved as it is supposed to.

$\endgroup$

1 Answer 1

0
$\begingroup$

The cause of this problem has been established as an NLA strip and track being added to an armature. Removing both allows the state colors to act as expected. I’m not clear on how any NLA data was added, as I don’t work with NLA and wasn’t even making edits to one of the armatures that developed this problem, but there is an easy way of resolving the matter.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .