I am trying to do automatic weighting on this object, but I am getting a "Automatic Heat Weighting: Failed to find a solution for one or more bones".

I have tried multiple things to fix this:

  • Applied: Location, Rotation & Scale
  • Recalculated Normals
  • Removed all modifiers

I still cannot get it to work. Here is the file if you want to take a look:



2 Answers 2


Try adding a subsurface modifier to the meshes you want to parent before you parent them. You can remove it later. For some reason it should work.

  • $\begingroup$ Thanks, I haven't had a chance to test it out, but I will take a look $\endgroup$ Jun 17, 2015 at 15:02
  • $\begingroup$ After testing, this worked! Sorry for the delayed response $\endgroup$ Jun 17, 2015 at 15:07
  • $\begingroup$ I tried this option and it didnt work, cuz when I tried to pose The body(mesh) didnt move with armature and clothes (mesh). $\endgroup$ Sep 18, 2018 at 3:11

By your question I suppose that you are using the "With Automatic Weights" method.

This method works better with manifold meshes. The size of the bones also influences the result: bigger bones will attract more vertices. Don't forget that one can add remaining parts by hand later by using vertex groups.

I tested user14351's method and it works for your model (except for the teeth) . You need to add a subsurf modifier before parenting the armature to the mesh.

  • 2
    $\begingroup$ by non-manifold I think you mean manifold :) $\endgroup$ Sep 16, 2015 at 19:08
  • $\begingroup$ Indeed @Jerryno! Corrected. Thank you so much for pointing out the error :). And sorry for the inaccuracy everyone! $\endgroup$
    – chicOrtiz
    Sep 8, 2016 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.