0
$\begingroup$

I remember backface culling used to mark flipped normals as red and correct ones as blue. Not sure if it's different with the newer versions, but backface culling is now only displaying the flipped normals as invisible for some reason

backface culling problem

How do I set this to mark the faces as red and blue like it used to?

$\endgroup$

1 Answer 1

2
$\begingroup$

Backface culling is a feature that hides backfaces. It is not supposed to mark them in any way, but prevent them from being rendered. If you wish to show backfaces, you need to enable Face Orientation overlay in the Overlays menu in the 3D Viewport:

enter image description here

Note that you need Backface Culling to be off for the material so that the backfaces are visible and the overlay is shown on them. If it's on, you will not be able to see the overlay as well for the backfaces, because they will not be rendered(in the viewport) at all.

It's also possible to choose the colors of the overlay in the Preferences, Themes tab, under 3d Viewport color section and it might be convenient to set the alpha of positive direction to 0 to not show it at all so you can still see your materials on the "good" side in Material Preview shading mode while working with this overlay on.

enter image description here

$\endgroup$
1
  • $\begingroup$ Thank you. I think I might have misremembered $\endgroup$ Commented Nov 8, 2023 at 0:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .