1
$\begingroup$

I know this is questioned a lot. I have been tried many ways but my stitch array doesn't follow the curve well. I have set curve & object origin to cursor. But still it apply very weirdly. with the huge distance and not following shape between curve & array.

I have also tried Ctrl+A - All transform and it is not work too. Does anyone has idea what is going on?

What could be wrong is when I move obejct, it goes opposite way also when curve modifier applied. (If you move to right, it goes left.)

Hope someone knows this issue.

enter image description here enter image description here

enter image description here enter image description here

$\endgroup$
4
  • $\begingroup$ hello please share your file: blend-exchange.com $\endgroup$
    – moonboots
    Nov 7, 2023 at 21:13
  • $\begingroup$ blender.stackexchange.com/a/65571/19307 $\endgroup$ Nov 7, 2023 at 22:27
  • $\begingroup$ @moonboots <img src="https://blend-exchange.com/embedImage.png?bid=WzEqQkbn" /> Here you are. actually I need to put stitch on the curve(Plane.021) Do you mind to try with that curve? $\endgroup$
    – UNSENT
    Nov 7, 2023 at 23:03
  • $\begingroup$ the "stitch" origin is probably in the wrong location. If you have applied all transformations to the curve then its origin is at (0,0,0). Deactivate all modifiers of the stitch object so you can see it, then move it to (0,0,0) and apply the location so the origin is also at (0,0,0). Align the object to the X or Y axis, apply the Rotation. Finally, set the used axis in the Curve modifier setting. $\endgroup$
    – Blunder
    Nov 7, 2023 at 23:04

1 Answer 1

0
$\begingroup$

Both the origin of the curve and of the object are too far from the objects, select them and right click > Set Origin > Origin to Geometry, then select the curve, ShiftS > Cursor to Select, select the object, ShiftS > Selection to Cursor:

enter image description here

Second problem: As you see the radius of the cuve vertices is not 1, it has been scaled when you've applied the scale of the curve, bring it back to 1, if you do it through right click > Set Curve Radius you need to type 1 then Enter

enter image description here

$\endgroup$
8
  • $\begingroup$ Thank you for the help! now it works with circle line. but I tried with same method on the shoes (stitch needs to be Plane.021). and it doesn´t work :( $\endgroup$
    – UNSENT
    Nov 8, 2023 at 9:00
  • $\begingroup$ I finally made object to follow curve. First, I did all transformation at 0,0,0. then made both Origin to Geometric, Curve Cursor to selected, Object origin to cursor. But somehow objects to follow curve has changed the form and they are extremely thin now. nothing look like original object. is this normal? $\endgroup$
    – UNSENT
    Nov 8, 2023 at 9:17
  • $\begingroup$ Make sure that the radius of the vertices of your curve are set to 1 (in Edit mode select all, right click > Set Curve Radius, type 1 and Enter) $\endgroup$
    – moonboots
    Nov 8, 2023 at 9:33
  • $\begingroup$ Yes, it's currently 1. If the shape of thread is "O" more less, the result is "I". no matter if I increase the stitch obejct thickness or not, it doesn't apply to the curve at all. I'm so sorry for the a lot of issue. $\endgroup$
    – UNSENT
    Nov 8, 2023 at 11:16
  • $\begingroup$ Could you please share the file with the new problem? $\endgroup$
    – moonboots
    Nov 8, 2023 at 11:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .