0
$\begingroup$

I have this big scene that has a lot of elements, and when I try to render the animation or even a single frame, sometimes it renders normally all the way through the end of the animation, and sometimes it cannot start the first frames because it runs out of GPU memory.

So what I tried to do that worked is that I restarted my laptop and outputted the frames in a new folder (because, from my observations, Blender for some reason runs out of memory if the folder has rendered frames in a past rendering), and it rendered.

Now there comes another big scene, and it runs out of GPU memory. Tried the same tricks I learned but nothing changed. I switched from Optix to CUDA, then the screen turned black; not the frame, but the actually laptop screen went black, and I could only see the cursor.

Blender wasn't even in the task bar, and I had to restart my laptop. The problem is, I already rendered a frame normally from this scene without any issues, I don't know what happened now.

I'm using Optix and Cycles, and my RTX 3070 has 8GBs of VRAM

$\endgroup$

2 Answers 2

0
$\begingroup$

Based on what you have said (a big scene with many objects in it) is it possible that you are trying to render with the viewport option most right? As shown below

enter image description here

This takes some amount of memory, so try to switch to the left one. If the problem persist, try to select the other left options going from right to left (Because they requires gradually less memory).

The fact that you have apparently inconsistent reactions could be due to the selection of different view port option, so you can have GPU's memory shortage for the same frame or not based on the selection. In some other case the memory could be enough for some frames, but then you encounter one with too many objects or textures to load, but part of the memory is currently dedicated to render you preview in the main blender tab.

enter image description here

$\endgroup$
1
  • $\begingroup$ That's not my case. I always enable the solid viewport before rendering. $\endgroup$ Nov 8, 2023 at 13:40
0
$\begingroup$

It's worth mentioning, that if you render at higher resolutions and with multiple passes enabled, the image itself can take a lot of memory, so you can enable rendering tiles. Properties Editor, Render tab, Performance panel, Memory subpanel, Use Tiling:

enter image description here

If you have fast rendering frames/image it might slow down your render significantly if you have many small tiles, but if it's a longer render it will not matter that much.

$\endgroup$
2
  • $\begingroup$ Tiling is already enabled. $\endgroup$ Nov 8, 2023 at 13:39
  • $\begingroup$ CLI rendering might save a little bit of memory, you can also pack and unpack all textures to a single folder and go through them to see if some can be reduced, but those are probably obvious things to do when trying to lower memory usage. $\endgroup$ Nov 8, 2023 at 14:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .