0
$\begingroup$

I am making this illustration of a 3D card and the effect that I want in the end is that it has some depth inside, so I made this folllowing setup:enter image description here

enter image description here there's the box, and the different layers of greasepencil distributed inside. As you can see, they are not on the same level.

enter image description here

In the shader editor, used this above in both of the greasepencil objects, and this on the box (that doesn't have the front face, because the other face (which came from a different cube) is the frame: enter image description here to make the box insivible in the final render, but you still couldn't see whats inside.

But when I rendered the animation, the layer that is supposed to be inside, shows like this: enter image description here

I tried making two separate greasepencils objects (one for the frame, another for the interior), but the final render, still does the same thing. How can this be solved? Did I do something wrong in the shader editor? I'm still new to blender, so I don't know how to make it.

$\endgroup$
5
  • $\begingroup$ Did you follow any specific tutorial or instructions or your are trying to figure it out yourself? Can you share your blend file for others to test? $\endgroup$ Commented Nov 6, 2023 at 21:57
  • $\begingroup$ I didn't follow any specific tutorial, I was just trying to apply the greasepencil principles that I learned on something new. But I made this wetransfer link available for the file, so you can have access: we.tl/t-oVcPzqWTgh $\endgroup$ Commented Nov 7, 2023 at 2:33
  • $\begingroup$ Hi Isla, thanks for sharing the file. Your problem is much clearer now. In Properties Editor click on View Layer tab and in Passes > Data turn on the Z pass. This will solve your issue. Just a tip: Transform the "creature details" layer of your frame GP object at -0.5 on Y axis. This will make the bubbles appear in front of the character. $\endgroup$ Commented Nov 7, 2023 at 9:41
  • $\begingroup$ Thank you! It worked! Why is this Z pass turned off when usually Im using the 3D space to use depth? that's weird $\endgroup$ Commented Nov 7, 2023 at 11:22
  • $\begingroup$ I am asking myself the same question - probably the option needs to be moved to the Grease Object settings instead of enabling Z pass globally. I suppose that Grease Pencil object is usually used as overlay of the 3D scene that needs to be always on top. Enabling Z Pass considers it as a real 2D object in 3D space. $\endgroup$ Commented Nov 7, 2023 at 13:14

1 Answer 1

0
$\begingroup$

As it was discovered by Rumen, the solution was simply to enable the Z Pass on the DATA on View Layer Tab. In the next Grease Pencil projects, I will be needing to be aware of this to bring the desirable results.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .