0
$\begingroup$

I am trying to import a Wavefront OBJ file exported from FreeCAD into Blender. I have tried importing a Surface and a Mesh. In both cases the resulting object in Blender is invisible. Looking in the Blender logs I get these errors:

OBJ element not recognized: 'newmtl color_cccccc'
OBJ element not recognized: 'Kd 0.800000011920929 0.800000011920929 0.800000011920929'
OBJ element not recognized: 'Tr 0.0'

I can import a solid body using the same method and this appears as expected.

When I import the mesh and select it, the status bar says it has components:

##

I've tried the Numpad . trick in case it is in a silly place or very small/large. This doesn't work. My exported OBJs and MTLs are here https://go.wetransfer.com/t-SftP1Rlezj

Any thoughts experts? Thanks!

$\endgroup$
1
  • $\begingroup$ The errors seem to be related to a material or so, could be that the OBJ file has material information that Blender cannot use. For the invisible object see my answer. $\endgroup$ Commented Nov 3, 2023 at 9:58

1 Answer 1

0
$\begingroup$

The Numpad . trick does work, however if you look at the dimensions of the object (I've imported the file with "Mesh" at the end), you see it is 5640 × 1500 × 2820 m in size:

dimensions

If you haven't changed the default clipping values of your viewport, it is set to Clip Start at 0.01 m and End at 1000 m. But the point from which the object is viewed after pressing Numpad . is certainly much more than 1000 m away, otherwise an object of that size would not fit the screen, therefore it is invisible (an indicator for the clipping issue is that even the grid disappeared):

clip too low

If you change the clipping values to something else like starting at 1 m and ending at 20000 m for example, the object will appear:

increased clip distance

By the way, the camera has clipping values for rendering as well in its Object Properties which are independent from the viewport settings, so if you are not going to change the size of the object you will have to take care of them too, if you don't want the object to disappear when you render it.

camera clipping

$\endgroup$
3
  • $\begingroup$ Aah very good. It's supposed to be in mm not m so no wonder it's huge. Weird as my default length units in both FreeCAD and Blender are m so there must be something going on there. Thanks! $\endgroup$
    – rubinho
    Commented Nov 3, 2023 at 11:07
  • $\begingroup$ @rubinho For the default units, it does not matter how they are setup, it depends on how the software saves and interprets stored values - and if there's a misunderstanding between those softwares it can come to this. Very simplified example (and no idea how the reality is here), let's take the 5640 m on X. Say FreeCAD saves values with a fixed amount of decimals like 3 and saves numbers without decimal point - it knows 5640 means 5.640 m but Blender could expect values containing a decimal point, so 5640 is interpreted as 5640 m. $\endgroup$ Commented Nov 3, 2023 at 11:14
  • $\begingroup$ @rubinho Please take your time to read this: What should I do when someone answers my question? $\endgroup$ Commented Nov 7, 2023 at 12:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .