1
$\begingroup$

I'm looking for help on rendering normals. I've rendered out normals without issue before, but something seems to be off now. Here's an image showing the problem.

Test

I'd expect there to be nothing on the baked normal map but just a circular indentation where the Hipoly differs from the Lowpoly. However I'm getting these lines across the map resulting in odd shading on the final image.

I've averaged the normals of both models, set to smooth shading, and applied all transforms. Color Space is set to Non-Color on the image node. I've tried baking both through Blenders bake process and using Textools with similar results.

Here is a sample blend file

Thanks for any help!

$\endgroup$
5
  • $\begingroup$ For both objects: 1, Object Data Properties Tab > Geometry Data > Clear Custom Split Normals. 2, set Auto Smooth angle to 180°.For baking: Cycles, Bake panel > Bake Type=Normal, enable Selection to Active, Extrusion distance set to 0.01. Then with image texture to bake to Active hit the Bake button. $\endgroup$ Nov 2, 2023 at 19:35
  • $\begingroup$ Hi, @3fingeredfrog .. I think you've given a more accurate answer than I was about to.. If you have a moment, could you post it as one, with a brief explanation of why it works? $\endgroup$
    – Robin Betts
    Nov 2, 2023 at 19:40
  • $\begingroup$ Sorry Robin, I would have liked to have answered with screen shots but because of bad weather here we have lost our internet connection and so only able to use phone therefor only able to comment. Perhaps you could give the answer ? $\endgroup$ Nov 2, 2023 at 19:50
  • $\begingroup$ I wonder why the current split normals mess up the baking though? $\endgroup$
    – moonboots
    Nov 2, 2023 at 20:36
  • $\begingroup$ Thank you @3fingeredfrog! Clearing Custom Split Normals worked. $\endgroup$
    – Lou
    Nov 2, 2023 at 20:51

0

You must log in to answer this question.

Browse other questions tagged .