3
$\begingroup$

I am using Blender 2.74. Is it possible to use transparent texture in the GLSL shading mode in BGE?

I can get it working in the multitexture mode thought. But no matter how I try, I can't get it working in the GLSL shading mode. Can anyone please explain how to get it working if it is at all possible.

Thanks for any insight.

$\endgroup$
4
$\begingroup$

First in Material tab enable Z Transparency and set Alpha to zero.

enter image description here

Then in the Material Texture you need to enable Alpha in Influence section.

enter image description here

$\endgroup$
  • $\begingroup$ Hi Denis: the transparency works in multitexture mode only, not in GLSL mode. $\endgroup$ – ShungChing May 5 '15 at 2:13
  • 1
    $\begingroup$ @ShungChing I use mostly GLSL mode, and thats the settings that work for me with the transparency. $\endgroup$ – Denis May 5 '15 at 4:27
  • $\begingroup$ @ShungChing I don't know why you say that. I've found that they only work in GLSL. $\endgroup$ – Scalia May 6 '15 at 16:05
  • $\begingroup$ @Denis: I've experimented different settings with the original file so much that I didn't get the transparency working even if I followed your instruction. I decided to delete the object and start all over again and it is working now! Thanks for the explanation and the excellent snapshots. $\endgroup$ – ShungChing May 8 '15 at 21:04
  • $\begingroup$ @VinceScalia: I should have tested the instruction with a new Blender session. Thanks for your input. $\endgroup$ – ShungChing May 8 '15 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.