2
$\begingroup$

I'm trying to cut holes into a cylinder top. My first step is to create a cylinder. Next I delete the bottom face. Then I solidify it to give it a thickness of .05m.
At this point my object looks like: enter image description here

Next I create a circle of diameter 0.2m. I go to edit mode and fill it in. Then I extrude it to make a long cylinder for my cutting tool. Looks like this: enter image description here

Now I move the cylinder to overlap with the face of the cylinder: enter image description here

Now I select the cylinder and add the Boolean modifier. I select the circle as my object and try to do a Difference operation. If I make the circle invisible, I see a hole cut into the top of the cylinder as I want: enter image description here

The problem occurs when I try to Apply the Boolean. No matter if I select Fast or Exact, I get the following: enter image description here enter image description here

Instead of a hole cut into the face, I have a hole with an extruded cylinder below the cut.

Why?

$\endgroup$
2
  • $\begingroup$ ... if this hole doesn't need to be animated, it's much easier just to I inset the face, and delete the middle, no oolean required.. but maybe this is just a simple case for illustration. $\endgroup$
    – Robin Betts
    Oct 31, 2023 at 8:01
  • $\begingroup$ Hello. Please check if you have inverted normal in either meshes. You can recalculate normals in edit mode with SHIFT + N $\endgroup$
    – Gorgious
    Oct 31, 2023 at 9:02

1 Answer 1

3
$\begingroup$

Select the cylinder and go into edit mode. Select all and press shift + N to recalculate normals. Select inside and go back into object mode. After applying the boolean modifier you should find that deleting the circle object leaves the hole in the cylinder.

$\endgroup$
2
  • $\begingroup$ That worked! Thanks! Can you explain why Recalculting Normals was needed? Any idea how I know when I need to perform that on other activities I may come across in the future? $\endgroup$
    – Motougo
    Oct 31, 2023 at 16:28
  • $\begingroup$ We needed to recalculate normals because the boolean modifer uses normals to determine which direction to cut the "hole". If you turn on face orientation you can better see how the normals work on the mesh, and I would disable the solidify modifer to get a better look. The boolean modifer "cuts" a hole from the "outside" of the mesh based on the direction the normals are facing. For future uses, any time you have boolean operations that don't seem to work the way you want them to, try flipping the normals. $\endgroup$ Nov 1, 2023 at 4:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .