6
$\begingroup$

As the title states, I am trying to save an image that I can see normally in the UV/Image Editor. I have done some compositing to it, and everything works inside Blender, but when I press F3 and save it to my desktop, the file that shows up there is blank, transparent. I have 3 render layers, all being affected by my composite nodes. In the layers tab at the bottom of the UV/Image Editor screen, I have Composite selected. It looks great inside of Blender, and I don't see why this isn't working. Any help would be much appreciated, thanks! If any extra info or screens are needed to try to help me solve the problem, please request!

$\endgroup$
  • 5
    $\begingroup$ Can we see the node setup (compositing) please? $\endgroup$ – VRM May 4 '15 at 14:09
  • $\begingroup$ i.imgur.com/4JnZbrt.jpg $\endgroup$ – Cold999 May 4 '15 at 14:12
  • $\begingroup$ Anything useful come up yet? $\endgroup$ – Cold999 May 4 '15 at 14:28
  • $\begingroup$ It's hard to tell, because the image resolution is not enough in this case. Is that Render Layers node in the bottom right, just above the nearest spaceship wing? It's showing there's no infromation. $\endgroup$ – Mr Zak May 4 '15 at 14:42
  • $\begingroup$ It actually does have a render, but is a really light slipstream type effect, and if I zoom in enough, you can see it slightly i.imgur.com/0lUG2L4.png $\endgroup$ – Cold999 May 4 '15 at 14:50
2
$\begingroup$

The problem is that the image you are saving is entirely transparent except for the lights on the wings. You can't see this in blender because you have selected the RGB display mode, which disables the effect of the alpha channel. If you select the RGBA display mode in the header of the image editor, then the problem becomes clear:

enter image description here

As a quick fix, you could disable Use Alpha on the composite node and then save the image as RGB instead of RGBA.

However, in case you want an alpha channel, then the cause of this lies in your compositing setup (Be sure to select RGBA in the header here too, so you can see what's going on).

Mix/Add nodes don't handle alpha very smartly on their own, so you'll have to handle alpha for them, or use some alpha over nodes.

Also note that add nodes literally just add the values of all the pixels together. As a result your spaceships are coming out a few times brighter than they would be.

Here I've remade your compositing setup, working from the bottom (here the bottom is the background, which goes under all other elements) to the top (lens flairs/bloom effects generally go above all other elements):

enter image description here

Compositing things in this order makes a lot of this alpha handling unnecessary, and generally avoids extra headaches.

$\endgroup$
  • $\begingroup$ Thanks a bunch! I am gonna try doing this now and I'll tell you the results I get. $\endgroup$ – Cold999 May 8 '15 at 7:45
  • $\begingroup$ I tried it out, and when I went to save it as a RGB it gave me the same black background with white light spots where the headlamps should be, could you send me that blend you fixed up please? It would be much appreciated. $\endgroup$ – Cold999 May 8 '15 at 8:04
  • $\begingroup$ @Cold999 I forgot to mention that you'll still need to disable Use Alpha. Otherwise the alpha channel will still affect the output, but will appear as black instead of transparent. I've uploaded the .blend with the reworked composite nodes $\endgroup$ – gandalf3 May 8 '15 at 20:45
  • $\begingroup$ Thanks a bunch! Really helped me out and it works like a charm! $\endgroup$ – Cold999 May 9 '15 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.