1
$\begingroup$

I create a mesh with this specific pattern and I need to connect this two edges without causing shading issue (img 1). If I just fill them with F key the shading doesn't work properly because the filled face isn't flat (img 2). The other option is to use a triangle but it may cause problems in the future (img 3). Is there any way to fill this gap smoothly with quads? enter image description here enter image description hereenter image description here

$\endgroup$
4
  • $\begingroup$ If you right click and Shade Flat it should work, if you just want to shade flat these faces, select it and Ctrl F > Shade Flat $\endgroup$
    – moonboots
    Oct 28, 2023 at 14:58
  • $\begingroup$ Thanks for the tip but I don't want to shade flat the faces. I just wonder how to connect them with flat quads.. $\endgroup$
    – DextinteR
    Oct 28, 2023 at 15:19
  • $\begingroup$ You say that you don't want to shade flat but the rest of your mesh is shaded flat $\endgroup$
    – moonboots
    Oct 28, 2023 at 15:22
  • $\begingroup$ Yea, I just showed the example but I forgot to mention that the transition has to be smoothed and beveled $\endgroup$
    – DextinteR
    Oct 28, 2023 at 15:26

1 Answer 1

1
$\begingroup$

Enable the Auto Smooth option, it will only smooth between the faces that have the angle that you determine, increase the angle value until you're good, don't push too much otherwise it will smooth between the faces that are perpendicular and give bad result:

enter image description here

To keep some edges unaffected by the smoothing, select these edges and press CtrlE > Mark Sharp:

enter image description here

$\endgroup$
2
  • $\begingroup$ Is it possible to adjust auto smooth angle for individual faces but not for the entire object? $\endgroup$
    – DextinteR
    Oct 28, 2023 at 16:01
  • 1
    $\begingroup$ Ctrl E >Mark Sharp? $\endgroup$
    – moonboots
    Oct 28, 2023 at 16:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .