1
$\begingroup$

Here is my situation: i have character that is a sphere (body) with another sphere inside (brain) and the surface of the body there are two discs (eyes) and another one (mouth). The rig start from the center (body_bone) from there i extrude 4 more bones. enter image description here

The physics should be apply only on the body but the other parts still need to follow the movement (example a jump: the physics will apply on the main body but the other parts will still follow the movement up and down of the jump). The problem is that when i creat an animation the parts follow the movement of the animation but the main body don't.enter image description hereenter image description here

Here is screen of my hierarchy

enter image description here

How can i fix it? If there is a need for more image or information i will add more.

here is the link to the file

$\endgroup$
8
  • $\begingroup$ what does it give if you parent the armature to the body? $\endgroup$
    – moonboots
    Commented Oct 26, 2023 at 14:25
  • $\begingroup$ no change when I run the animation, the children do not move with the parent. I mean it does kinda follow the animation up and down but it's all desynch. Like the main bone and it's children with the objects follow the animation but the main sphere do what it want kinda. but if don't use any physics it works fine $\endgroup$ Commented Oct 26, 2023 at 15:16
  • 1
    $\begingroup$ please share your file: blend-exchange.com $\endgroup$
    – moonboots
    Commented Oct 26, 2023 at 15:31
  • $\begingroup$ You did not mention which physical simulation you are using. Are you using both Cloth and Soft Body at the same time? (see outliner, last screenshot) - Have you tried vertex parent or object parent? $\endgroup$
    – Blunder
    Commented Oct 26, 2023 at 15:40
  • 1
    $\begingroup$ @moonboots i added the file $\endgroup$ Commented Oct 27, 2023 at 15:40

1 Answer 1

0
$\begingroup$

In Object mode, unparent the body object (AltP > Clear Parent), choose either Cloth or Soft Body (if you choose Cloth disable the Pressure option, if you choose Soft Body disable the Goal option), close the armature action in the Dope Sheet, select your armature, shift select your body object, switch to Edit mode, select 3 of its vertices and CtrlP > Make Vertex Parent:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .