0
$\begingroup$

I recently Bought the AMD Rx580 graphics card for my blender . But the latest Version of blender didnt support my graphics card since its using HIP.. So i tried to install the older version 2.93 to check whether OpenCL can support my graphics card or not for GPU rendering Cycles...But still it shows " No compatible GPUs is found" as shown in below image .. What should i do now.. Someone help me please

enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ As mentioned in Blender 2.93's Cycles GPU requirements documentation, your GPU should theoretically function, but you need to install specifically the "Pro" drivers from AMD, which should be this one for an RX 580. Try a clean installation of that driver if needed, reboot, and see how it goes. Otherwise, I would suggest trying to report a bug, but I doubt the devs will do anything for an unmaintained version. $\endgroup$
    – Lauloque
    Commented Oct 26, 2023 at 2:43
  • $\begingroup$ see my answer bellow $\endgroup$
    – Lauloque
    Commented Oct 26, 2023 at 2:48
  • $\begingroup$ Can You tell me Which specific drivers I should install? I tried Raedon ProRender Version 3.6, but when i try to enable the addon Blender automatically closes or crashes $\endgroup$ Commented Oct 26, 2023 at 2:49
  • $\begingroup$ ProRender isn't a driver, it's a render engine. Again, see my answer. $\endgroup$
    – Lauloque
    Commented Oct 26, 2023 at 2:53
  • $\begingroup$ blender.stackexchange.com/questions/245136/… $\endgroup$ Commented Oct 26, 2023 at 5:14

1 Answer 1

2
$\begingroup$

As mentioned in Blender 2.93's Cycles GPU requirements documentation:

OpenCL is supported for GPU rendering with AMD graphics cards. Blender supports GPU rendering on graphics cards with GCN generation 2 and above. To make sure your GPU is supported, see the list of GCN generations with the GCN generation and supported graphics cards.

On Windows and Linux, the latest Pro drivers should be installed from the AMD website.

Your GPU uses GCN4 (source), so it should theoretically function. But you need to install specifically the "Pro" drivers from AMD, which for your RX 580 should be there:
Radeon™ RX 580 Drivers & Support | AMD

Try a clean installation of that driver if needed: uninstall whatever AMD driver you have, reboot, install the new one, reboot, and only then open Blender to see how it goes.

Otherwise, I would suggest trying to report a bug using Blender's menu Help > Report A Bug, but I doubt the devs will do anything for an unmaintained version.

$\endgroup$
5
  • $\begingroup$ Thank You so much .. I installed the driver . Now what should I do? $\endgroup$ Commented Oct 26, 2023 at 2:57
  • $\begingroup$ again, see my answer ;) $\endgroup$
    – Lauloque
    Commented Oct 26, 2023 at 3:00
  • $\begingroup$ Thank You so much I followed the steps and installed driver..but linux doesnt allowing to install it .."permission denied" is displayed . $\endgroup$ Commented Oct 30, 2023 at 2:36
  • $\begingroup$ BSE is only for questions about Blender (plus I don't know much about Linux). If you need help installing drivers on Linux I suggest you to ask that specific question on Super User, don't forget to mention precisely which Linux distro you are using as answer vary from that. $\endgroup$
    – Lauloque
    Commented Oct 30, 2023 at 13:59
  • $\begingroup$ Okay Thank you for your time $\endgroup$ Commented Nov 1, 2023 at 6:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .