4
$\begingroup$

I am using Blender's game engine to make a racing game. To have the camera follow the car, I parented the camera to the car. The camera tracks it fine on straightaways, but not so much on turns. Around the turns, the camera rotates at such an angle that the car goes to the side of the view.

enter image description here

As you can see, the camera does sort of an ovular rotation. How do I stop the camera from doing this?

$\endgroup$
  • $\begingroup$ are you rotating the camera ? (or the camera has nothing except the parenting $\endgroup$ – Chebhou May 4 '15 at 0:04
  • $\begingroup$ The camera is just parented to the car, it is not set to rotate on its own. $\endgroup$ – Henry V May 4 '15 at 0:07
  • $\begingroup$ I can't think of something so maybe the file could help $\endgroup$ – Chebhou May 4 '15 at 0:14
  • 1
    $\begingroup$ I fixed this by using a camera actuator that is always going instead of parenting the camera to the object. $\endgroup$ – Henry V May 4 '15 at 0:44
  • $\begingroup$ great! you can write and accept your answer ( don't make it one sentence ) $\endgroup$ – Chebhou May 4 '15 at 0:45
5
$\begingroup$

To fix this, I applied a camera actuator to the camera instead of parenting the camera to the car. The camera actuator allows the camera to track an object and choose how precisely it tracks it using damping (e.g. if the car goes over a pothole it won't shake the camera, but if it goes over a big hill, the camera will follow it). Here is a picture of the actuator settings:

enter image description here

You can learn more about camera actuators here.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.