1
$\begingroup$

I am trying to learn how to use Geometry Nodes and have run into an odd issue. When I use a Geometry Node to manipulate the geometry (at the very least, use the Transform Geometry node), it causes Boolean Modifiers to not work correctly.

Cube with Boolean Modifier: Cube with Boolean Modifier

Icosphere with Geometry Node: Icosphere with Geometry Node (basically the Geometry Node is suppose to ensure that the Icosphere is half the size of the cube)

Expected Behavior: Expected Behavior

If I move the cube at all, even 0 units, suddenly the Boolean Modifier works. I would be okay with this except it fails every time I load the file. If I close it and reopen the file, the Boolean Modifier fails again. More importantly, if I link the object/collection in another file, there is no way to get the Boolean Modifier to work (non that I've found anyways).

I have tried using a Geometry Node on the Cube to perform the Boolean operation, but this failed as well. It is also worth noting that the Boolean Modifier is not reflected in the Render, even if I use the move 0 units trick.

Also, the Boolean Modifier works as expected if I apply the Boolean Modifier, but I'm trying to do this non-destructively.

Any idea what I'm doing wrong/why this is happening?

$\endgroup$

1 Answer 1

0
$\begingroup$

$\hspace{15pt}$The problem is that you have a dependency cycle. The cube's Boolean modifier depends on the geometry of the icosphere, but the icosphere's geometry is modified by its Geometry Nodes modifier, which depends on the cube's geometry.

$\hspace{15pt}$To solve that you can:

  1. Use a hidden duplicate of the cube without the boolean modifier in the icosphere's Geometry Nodes.

$\hspace{15pt}\text{Or:}$

  1. Do everything in the cube, using Geometry Nodes. And use an empty to control the location of the icosphere.

The cube's Geometry Nodes:


$\text{Blender 3.6}$

$\endgroup$
4
  • $\begingroup$ This makes sense. I hadn’t considered the dependency of the geometry. Thank you! $\endgroup$ Oct 22, 2023 at 4:52
  • $\begingroup$ I was a little too hasty, I think. I tried option 1 but ended up with the same issue. I created a completely new cube and used the new cube in the Icosphere's Geometry Node. However, the Boolean Modifier on the original cube is behaving the same way. Does this mean there is more than a dependency issue? $\endgroup$ Oct 22, 2023 at 18:07
  • $\begingroup$ Disregard this. I recreated the file and option 1 works now. Either I just don't know what I'm doing or Blender is playing some cruel trick on me. $\endgroup$ Oct 22, 2023 at 18:23
  • $\begingroup$ @JesseyYeager I added the .blend file to the answer just in case. $\endgroup$
    – Hulifier
    Oct 22, 2023 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .