1
$\begingroup$

ANOTHER UPDATE

Bool Tool seems to union, difference, and intersect in the way that I expect. I later noticed this issue again even with the updated version. https://docs.blender.org/manual/en/latest/addons/object/bool_tools.html

END ANOTHER UPDATE

EDIT UPDATE Here is the .blend file

END UPDATE

Two possible solutions

  1. Upgraded from Blender 3.0.0 to Blender 3.6.5
  2. Was not using Merge by Distance

I am trying to make a custom gear to attach to my 6V motor. In short, I could use help with the correct steps to use a boolean modifier on a gear in Blender so I can create the desired shape. I come from a openSCAD background and trying to learn Blender 3.

Using the Extra Objects add on I am adding a gear from the mesh selections. I am able to export this to an STL and I can slice this correctly in Cura.

When I import the axle shape to remove I use the boolean modifier on the gear and make sure to hit apply. If I hide the imported object the full gear shows as if the boolean was not performed.

I tried to solidify the created gear, thinking that might be part of it. However I am unable to get the boolean modifier to apply as I wish.

I decided to see if I could get the boolean modifier to work on a cylinder, I see the correct shape in both object and edit mode. Exporting to STL using selected items I am able to view the STL in Cura. And slicing works as expected.

So I decided to create a gear where the cylinder is the base. Remove the axle and apply the boolean modifier. Add the gear around the cylinder with enough base to overlap. Join these objects. Shows up in Cura with xray errors and slices incorrectly. I am pretty sure this is due to me creating the object in Blender incorrectly as I have seen this with other objects and been able to adjust my design.

Blender object Cura open file and xray error Cura slice Working

$\endgroup$
2
  • 2
    $\begingroup$ The gear that you added using Extra Objects: you are saying that the boolean modifier doesn't work on it? It works fine for me. I selected the edges around the top and bottom centers and pressed the F key. I checked the face orientation. I created a cutter object. Then selected the gear, added the boolean modifier and selected the cutter object. It appears to be OK when checked with the 3D Print Toolbox. If you still have a .blend file with the Extra Objects gear you made with the imported cutter and upload it to blend-exchange.com it would make it easier for someone to help you. $\endgroup$
    – curious_1
    Oct 20, 2023 at 1:45
  • $\begingroup$ Thank you for replying. Here is a file.io copy of the .blend file. file.io/BaTj6vUOIeIK I tried again, I had not done the F key. While in Edit Mode if I press F once I ddo see an adjustment to the number of verticies. Pressing F again causes the gear to be incorrectly created. Best I can tell this is to switch to UV Face Select Mode, but most search results are for the F Keys. I think you are onto something here. One adjustment I made was to make the cutting object the same thickness as the gear, shows in blender ok, but cura still does not recognize the removed section. $\endgroup$ Oct 20, 2023 at 23:33

1 Answer 1

2
$\begingroup$

I get this message at the file link you provided: "The transfer you requested has been deleted."

As a guess it's possible that you have some duplicated vertices. Have you tried Merge by Distance when in Edit Mode?

This is what I did. If Merge by Distance didn't fix your gear, maybe this will help.

I added the gear and selected the edges Of the Base diameter. This is in wireframe so it is easier to see:

enter image description here

Then I pressed F to fill those areas. The image shows the top, but the bottom is the same:

enter image description here

I pasted in something to use for a boolean cutter, selected the gear, added the modifier as shown:

enter image description here

The result after applying the modifier and the 3D Print Toolbox information. The Non-Flat faces are caused by the cutter I used:

enter image description here

$\endgroup$
3
  • $\begingroup$ I edited the original post with the link of the blend-exchange you recommended this time. In the mean time, I will try these options you have suggested. $\endgroup$ Oct 21, 2023 at 18:17
  • $\begingroup$ I realized I was on Blender 3.0.0, ugrading to 3.6.5 seems to have solved this. However, I also gained some improvment to this print by using Merge to Distance. Thank you for your help. $\endgroup$ Oct 21, 2023 at 18:38
  • 1
    $\begingroup$ @JabberwockyDecompiler I'm glad I could help. I don't know if it was the case with your object, but when you are extruding a vertex and you press Esc, it creates a duplicate of the vertex. In that case you can either press Ctrl + Z after Esc, or use Merge by Distance to remove any "extras". $\endgroup$
    – curious_1
    Oct 21, 2023 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .