1
$\begingroup$

I am trying to add an HDRI to my scene and for some reason one version is showing up in the render view (the one I added) and another is showing up in material view (a default image). The world material globe is also black. Took me a while to get that HDRI to work in render view but before that it was all black.

Material View

enter image description here

Render View

enter image description here

Ive looked every where for the answer and tried a few things but I cant get it to be consistent. Any help would be very appreciated. If you need anymore screen shots, Im happy to send them. Thank you!

$\endgroup$
4
  • 1
    $\begingroup$ Hello, in Material preview, by default, you'll see a default HDRI, while in Rendered preview you'll see your own HDRI (i.e. the one selected in the World material). Not sure why it appears black on the sphere though. Maybe pack your images (File >External Data >Pack Resources) and share your file? $\endgroup$
    – moonboots
    Oct 20, 2023 at 6:37
  • $\begingroup$ I found out there was a glitch in the version I was using which caused the sphere to be black. Odd since it never did that before. I updated blender on my computer and it fixed the black sphere issue. Is there a way to use my own HDRI in the material mode as well as rendered or is that how it runs? $\endgroup$ Oct 20, 2023 at 21:47
  • 1
    $\begingroup$ Sure you can use your World HDRI in Material preview, you need to go into the Viewport Shading panel (top right) and enable Scene World $\endgroup$
    – moonboots
    Oct 20, 2023 at 21:59
  • $\begingroup$ Awesome! Thank you. I had a feeling it was something simple but couldnt find it. Appreciate the help. $\endgroup$ Oct 20, 2023 at 22:09

0

You must log in to answer this question.

Browse other questions tagged .