0
$\begingroup$

Im not the best at blender but I've been hacking away at this issue to no avail. I have a transparent image as a texture in blender but in rendering it shows with a black background... I've researched the issue a lot and I will link the methods I've tried down below as well. I'll attach a video of my blender too so you can see what the issue is.

Additional info: All of this was imported through pc2 export from CLO3d, I'm on a Mac and im using Eevee

Already tried all of these node setups:

https://artisticrender.com/how-to-use-alpha-transparent-textures-in-blender/

Add a transparent image on top of a material

Texture with transparency becomes black

EDIT: Added the pngs I used Image that was compiled in PC2 Seperate image I used

$\endgroup$
6
  • $\begingroup$ Hello could you please share your file (remove all the useless parts and pack the images)? $\endgroup$
    – moonboots
    Commented Oct 19, 2023 at 9:38
  • $\begingroup$ There is something strange in your video - the Image Texture node has the Alpha settings greyed out as if they were not available... usually even on an image without alpha transparency you can change those settings... so maybe uploading your file would be a good idea. By the way, the "How to set up a material for transparency in Blender" section of that artisticrender site is nonsense. With the Principled BSDF node it is not necessary to mix it with a Transparent BSDF node by the alpha channel as factor, but I noticed you did not do that in your video anyway. $\endgroup$ Commented Oct 19, 2023 at 10:27
  • $\begingroup$ @GordonBrinkmann I have tried using the image compiled in the pc2 zip from clo3d as well as a separate file with the exact same image as png and it comes with the same results. I'll add both of the files in an edit. $\endgroup$
    – lyte swag
    Commented Oct 19, 2023 at 10:46
  • 1
    $\begingroup$ Well, this site is focusing on tools and addons shipped with Blender, I have no idea what this pc2 export from CLO3D does. At least I know now why the alpha option is deactivated in the texture node: you have modified the image (intentionally or accidentally?) in Texture Paint mode and not saved the changes. The other thing is, I don't know which render engine you are using, but the Material Preview (which is visible in the video) always uses Eevee. Therefore you have to change the Blend Mode in the material settings to something else than Opaque to get alpha transparency. $\endgroup$ Commented Oct 19, 2023 at 12:03
  • 1
    $\begingroup$ The second answer in the link Texture with transparency becomes black which you had posted yourself in the question would have given you that solution already. $\endgroup$ Commented Oct 19, 2023 at 12:20

0

Browse other questions tagged .