0
$\begingroup$

I tried to add shadow catcher to the scene I was working on. I reduced a blend file that I was working on to a simplest scene with a cube and a plane and still couldn't make shadow appear on the plane. Creating a separate file, adding a cube, a plane, the same camera and light setup plus shadow catcher plane allows seeing a shadow and I couldn't figure out what is the key difference that can make shadow disappear.

In both cases I use Cycles with Transparency turned on. Camera and lighting setup is identical in both cases. Shadow catcher plane is just a mesh plane added in a center of coordinate axis with Shadow Catcher Mask enabled.

I'm using Blender 3.6.

Here is the problematic file: https://blend-exchange.com/b/j5Og5er8

Here is the file created anew, same scene setup, same Camera, Shadow Catcher and Light setup, shadow catcher works as expected: https://blend-exchange.com/b/mAzkJK5X

This question is similar to Shadow catcher not catching shadows however:

  1. The version of Blender is more recent.
  2. I can achieve catching shadows, but only for a file that I create anew in Blender 3.6.
$\endgroup$

1 Answer 1

1
$\begingroup$

Comparing properties one by one I found one that was to blame in my case and it was due to bpy.context.view_layer.cycles.use_pass_shadow_catcher set to True! It can stay initialized with the default value which is False and that'd suffice in my case.

Hopefully it'd help someone.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .