1
$\begingroup$

I am trying to get clear glass material. There is to much reflection on glass. How can I fix this reflection of light. enter image description here Edit:- I tried fixing outer glass. Please help fixing the bulb glass bit accurate.

Edit :- How to avoid this light sphere. enter image description here

Thank you.

$\endgroup$
7
  • $\begingroup$ Hello, maybe show some screenshots of your object and material, maybe you could mix your glass material with another one, or use an Input > Light Path node, etc $\endgroup$
    – moonboots
    Commented Oct 15, 2023 at 8:48
  • $\begingroup$ Please check the edit $\endgroup$
    – Anil
    Commented Oct 15, 2023 at 9:00
  • $\begingroup$ mmh I'm not sure what's happening, maybe share your file (only the lamp)? $\endgroup$
    – moonboots
    Commented Oct 15, 2023 at 9:04
  • $\begingroup$ You can download it from here we.tl/t-Dehybysf9c $\endgroup$
    – Anil
    Commented Oct 15, 2023 at 9:16
  • $\begingroup$ That blend file doesn't include any materials at all so we have no idea what settings you are using. Please share a file with your materials via blend-exchange.com following the instructions there to copy the link on that page and then edit your question here and paste the link into it $\endgroup$
    – John Eason
    Commented Oct 15, 2023 at 10:02

2 Answers 2

0
$\begingroup$

The properties of the glass BSDF shader consist mainly of the values roughness and IOR. An IOR´ is meaningless without a volume within which the IOR` applies. Your light bulb and the glass windows of the lamp are just surfaces and planes. Thus the glass shader lacks important properties on which it can operate.

Give the bulb and especially the glass windows (since the reflection problem is primarily one of the glass windows) a thickness so that the glass material can actually behave like a glass.

The easiest way to achieve this is the solidify modifier.

I'm not sure if that alone will solve your problem, but I'm sure that without such a change (giving the glass a thickness, a volume) you will never get a realistic representation.

$\endgroup$
5
  • $\begingroup$ Yeah, I gave thickness to glass window it is fine. But bulb is not working fine. $\endgroup$
    – Anil
    Commented Oct 15, 2023 at 11:14
  • $\begingroup$ "But bulb is not working fine." What does that mean? $\endgroup$
    – maddes8cht
    Commented Oct 15, 2023 at 11:17
  • $\begingroup$ When I added light in bulb it's creating Light sphere. How to avoid it. I attached image in question. $\endgroup$
    – Anil
    Commented Oct 15, 2023 at 11:34
  • $\begingroup$ Hello, please try to keep your question in a consistent form. It is okay to improve a question by further editing it, but it should always be clear to a new reader: what is your Problem? What is your Question? You added your recent image above the others. Please make clear that this already is a later image with changes intruced by an answer, and there is still need for further improvement. Lastly: What did you do with the bulb so that now there is this sphere? I can't imagine this is the result of appling a solidify modifier? $\endgroup$
    – maddes8cht
    Commented Oct 15, 2023 at 11:47
  • $\begingroup$ I will make it clear. I was in bit hurry so I just added the image and didn't checked the where it was placed. I didn't did much just added point light in the bulb. I there any way we can remove that sphere without removing light. $\endgroup$
    – Anil
    Commented Oct 15, 2023 at 12:23
0
$\begingroup$

What you see is the reflection of the Point light, maybe you should disable the Multiple Importance option which seems to make the Point reflection invisible and instead use an Emission node for the bulb material so that you keep a bright object. You won't see the filament anymore though, you could use an Input > Geometry node, Backfacing output as a factor to keep the filament visible, and use an Emission for the filament as well.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .