1
$\begingroup$

If I create a simple shiny metal material, by using Principle BSDF, crank up Metallic to 1.0, and drop the Roughness down, then apply it to a sphere and a cube. I get this: glossy metal material applied to sphere and cube, with smooth shading

The sphere looks good, but the cube does not. I think I understand what's happening: the sphere has a convex surface, so it reflecting the whole environment texture, but the cube is flat and therefore only reflects a small portion of it. But the small portion looks blurry.

How do I get a realistic-looking shiny cube? Do I need infinite resolution in the environment texture? Does the environment need bringing closer? Have I got the wrong idea completely?

Edit: as per someone's suggestion, I switched to Render Preview, added a world environment texture, and I also switched to Cycles rendering. The image below is the result - still a blurry and unsatisfactory cube! enter image description here

$\endgroup$
4
  • $\begingroup$ please pack your image and share your file $\endgroup$
    – moonboots
    Commented Oct 9, 2023 at 13:53
  • $\begingroup$ Sorry, I'm new to this forum, and I don't quite understand your comment. Do you mean share the .blend file? How can I do this? Thank you! $\endgroup$
    – Siskin
    Commented Oct 9, 2023 at 14:16
  • $\begingroup$ To pack the image, go into File > External Data >Pack Resources, and to share your file use a platform like workupload. It's weird that your HDRI seems blurry if the Roughness value of your material is at 0... $\endgroup$
    – moonboots
    Commented Oct 9, 2023 at 14:19
  • $\begingroup$ workupload.com/file/2Nu7g7LCjZc $\endgroup$
    – Siskin
    Commented Oct 9, 2023 at 14:24

2 Answers 2

1
$\begingroup$

Put the Roughness of your Principled BSDF at 0 and the glossiness will be maximal and sharp (the sharpness will also depends on the HDRI resolution by the way):

enter image description here

$\endgroup$
1
  • $\begingroup$ Amazing, thank you! $\endgroup$
    – Siskin
    Commented Oct 9, 2023 at 14:39
2
$\begingroup$

You are viewing your objects through "Material Preview" mode (aka LookDev) - this mode uses a hidden (blurred out) HDRI for the lightings and reflections. You can either extend the viewport shading options (top right of the viewport next to the 4 "circles" - click the little arrow) "and unblur" the world (second image), or use Render Preview mode, which requires you to provide your own HDRI in the World Shader (good free ones can be found here - https://polyhaven.com/hdris).

Shade1

Shade2

Notice the "blurry reflections" are simply a good reflection of a blurry HDRI.

$\endgroup$
1
  • $\begingroup$ Thank you, Christopher. I have edited my question with the results of your suggestion. I still don't think the cube looks right! $\endgroup$
    – Siskin
    Commented Oct 9, 2023 at 13:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .