After a two week long creative process of modelling my robot it was finally time to rig it. The tedious but easy part I thought. I had done it so many times before why would it be different this time? (Screams of pain)

enter image description here

Here's the leg shot. Looks normal. Every part is an individual mesh that I individually set parent to bone. There shouldn't be any deformation by my knowledge and I even turned off the Deform setting in Bone Properties. BUT enter image description here

When I bend the knee the joint VERY clearly deforms due to the fact that it's no longer a perfect circle. AND THE SAME THING HAPPENS WITH THE FOOT JOINT. Also I don't even have to bend the knee for it to deform. Having the leg perfectly straight but in a different position also deforms the joint! enter image description here

I have tried almost everything I can think of. At first I thought it had something to do with my IK rig so I removed just about everything creating an FK Rig. But it still deformed. Joining the meshes, locking the scale, parenting to object and turning off the deform setting on everything even though it doesn't seem to change anything! I'm out of ideas and frustrated so I've turned to the stack exchange for help. Any ideas for why this happens or if there is a setting that can force something to not deform?

  • 1
    $\begingroup$ Maybe you've scaled your armature in Object mode? In that case apply the scale. If it's not the problem please share your file $\endgroup$
    – moonboots
    Commented Oct 8, 2023 at 10:06
  • $\begingroup$ Oh-My-God... The armature was scaled higher in the Z-axis. Yup that fixed it. You are an actual life saver. Maybe leave that as an answer so I can give you points. $\endgroup$
    – Venik Hue
    Commented Oct 8, 2023 at 10:35

1 Answer 1


You've scaled your armature in Object mode, you just need to apply the scale (CtrlA).


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .