1
$\begingroup$

I downloaded some files from PokeMiners regarding their ripped 3D models from Pokemon GO. But when I downloaded Bulbasaur, I discovered that the eye image only included the sclera, pupils, and irises.

enter image description here

I didn't think much of it at first, but when I brought the model into Blender and added the textures, this occurred:

enter image description here

No matter what I tried, I always got two results: either the alpha was see-through, or the alpha was rendered black.

Eventually, by complete accident, I stumbled upon this peculiar detail:

enter image description here

It turned out that the 'alpha' had some metadata that did render the material that goes around Bulbasaur's eyes (see the red circle for full texture and highlighted text for which one in particular). And using the 'Add Alpha' brush, replace the alpha with texture, resulting in:

enter image description here

Bulbasaur no longer looks out of place, so, technically, the problem is solved. But I do have a question that still hangs over my head: Is there a way to import an image of this caliber without the alpha being rendered as alpha and instead with the material that is missing? For example: if the original image is the first picture, how to import it with the details of the last picture below?

enter image description here

(Bulbasaur's Original Files Here: https://github.com/PokeMiners/pogo_assets/tree/master/3D%20Assets/Addressable%20Assets/pm0001/pm0001_00_Rig%20%2345)

$\endgroup$

1 Answer 1

0
$\begingroup$

Use Channel Packed Alpha

Change the Alpha setting on the Image Texture Node for the eyes to Channel Packed

enter image description here

$\endgroup$
1
  • $\begingroup$ Worked like a charm! Thank you very much! $\endgroup$
    – Xavier
    Oct 9, 2023 at 1:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .