0
$\begingroup$

So far I have not found anwer, VBD volumes looks of course good on Cycles, but i wanna use them for simple stuff on EEVEE, but, most of the times, they barely work or are visible on render, i moved the density on the principled volume, changed the settings on volumetrics, distance etc, and nothing

Here is what Im talking about

This is how it looks on the viewport, solid

And this is how it looks when I switch to rendered view, of course it looks worse when rendering

Top one is how it looks on viewport, the bottom one is how it looks when switch to rendered, and looks worse when hit render, i knwo could be easy to just go to cycles, but i want this work for eevee too No matter how much i move density, antisotropy, samples, distribution,end or start, most of the times the VBD is basically invisible, UNLESS, the camera is really close

EDIT:

Sorry i forgot to add how i have the settings, but as I said, it doesnt matter, it doesnt work, for me, no, its not disabled on render: enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ Without seeing any settings (just knowing "no matter how much" you tried get it to work) it is hard to tell anything. I never use Eevee for, but a quick test showed me it works. When the camera needs to be really close that is a hint it could be a problem with start or end values. You say you tried that... but in which range? And what are the dimensions of your scene? Many missing informations to give an answer. Please provide more details or even better, upload the file to blend-exchange.com (you cannot pack the vdb inside the file though, but to check your settings it's okay) $\endgroup$ Oct 6, 2023 at 6:27
  • 1
    $\begingroup$ +1 GordonBrinkmann ... one forensic tip from me :), contrasted image shows some shadows on building, so probably you have disabled VDB from rendering in Outliner ... $\endgroup$
    – vklidu
    Oct 6, 2023 at 7:17
  • $\begingroup$ + 1 @vklidu Good idea as well. But would this make the smoke show up when the camera is very close? $\endgroup$ Oct 6, 2023 at 10:20
  • $\begingroup$ Sorry, but now you are wasting your time ... as said by Gordon - please share your blend, you can delete all objects in the scene, keep just a volumetric object and the light source you use to light the scene (we need to see whole scene setup). To share file you can use blend-exchange mentioned above but for .vdb file you would have to use another way (vdb can't be packed just linked and BSE allows you to upload only blend file kind. $\endgroup$
    – vklidu
    Oct 9, 2023 at 9:02

1 Answer 1

0
$\begingroup$

I have the answer to this! Go to the render panel for Eevee, scroll down to the volumetrics section, and increase the end distance as much as necessary. That should fix it! enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .